swx2004sp4 cannot resolve relations if i change part's size

hi all.
with swx2004 we're experiencing a *big* problem and our var doesn't
know how to help us.
i made a little ascii drawing at the end of this post to show you the
"side" view of the assembly you need to see our problem.
let's take a tipical situation: take 2 long bars, for example
70x100x1500 mm. now take 2 small blocks, let's say 10x20x50 mm and put
some relations between them:
- 10x50 face of the blocks to be complanar with 70x1500 faces of the
long bars
- 50x20 face of the blocks to be complanar with each other
- 10x20 "external" faces of the blocks to be complanar with the
"external" 100x1500 faces of the long bars.
at this time, we have built a support/spacer for a "traverse" between
long bars (this traverse will be built later).
now set up a couple of relations to keep the bars parallel each other
and on a plane of your choice. the only thing that must be free is the
distance between long bars, that will be defined by the length of the
traverse.
now extrude a fifth part, let's say a 50x70x500 mm big one.
now let's create the problem:
- 50x500 face must be complanar to 10x50 faces of the small blocks
- 50x70 faces must be complanar to the "external" faces of small
blocks (and, consequently of the long bars)
- 70x500 "upper" face must be complanar to 50x20 faces of the small
blocks.
if i explained well and you keep the 2 long bars "vertical" --from
your point of view--, you should see 2 long bars with 2 small blocks
"welded" to it and a traverse bar welded on these small blocks.
side view:
+--------------+
| |
Reply to
Gianni Rondinini
Loading thread data ...
I probably misunderstand but I can't see how a bit 500 long can effectively have coplanar relations of its ends with a bit 1500 long... however I was wondering from your description if your fifth part is an in context part and the change of block thicknesses produces a mate conflict as the changes are in transition. i.e. one part is 15 and the other is 20 and also required to be parallel... if that makes sense.. ...probably that wasn't helpful... but I mean well : )
Reply to
neil
I'd be glad to help you troubleshoot. Take the underscores out of my email address to send the zip file.
It could be an incontext relation, or mates, or a configuration problem or a subassembly issue or etc. Did you try ctrlQ?
matt
Gianni Rondinini wrote in news: snipped-for-privacy@4ax.com:
Reply to
matt
i'm sorry i wasn't clear enough :) since the 2 blocks are 2 instances of the same part, when you change thickness of one part, the other one shrinks too.
thank you :)
Reply to
Gianni Rondinini
--- now double click on the small blocks and change their thickness: for
---
Reply to
Eddie Cyganik
Gianni:
The first thing I see is that all the mates to the ...201 and ...025 parts have lost references (yellow triangles). Did you send it in this state? Is this the problem you're talking about? If I change the 20 to 15, then the mates don't solve, and it is because there are a lot of mates with lost references (15 broken mates).
After I repaired those mates with what seemed the obvious choices, everything updated fine.
I'll send you back the assembly file, which is the only thing I changed. This sounds too easy, I suspect I've missed something.
matt
Gianni Rondinini wrote in news: snipped-for-privacy@4ax.com:
Reply to
matt
no, everything was fine when i used swx explorer to back up all these files. but changing 20 -> 15 caused all those triangles to show up.
i saved your assembly on our network drive and told the person working on that assembly to open it and check if it's ok. by now, thank you very much --later i'll see what you changed in the assembly, too--.
i'll let you know asap.
regards.
Reply to
Gianni Rondinini
and you sent back to me your updated assembly. well, it actually happens that: 1. the first time we open your assembly, mates resolve fine 2. if i ctrl+q, everything still works fine 3. if i change the "thickness" of 201 part, mates won't resolve fine anymore 4. if i get back to the old thickness changing it by hand or undo-ing changes, mates won't resolve fine anymore
i can't guess what's happening :(
my var says it's a matter of our installation/setup, but this answer doesn't solve much of the problem :(
any more hints?
regards,
Reply to
Gianni Rondinini
It is definitely working properly here. I'm using 2004 sp3. There is no problem with the way the part is built, it looks simple enough. There are none of the other problems I was worried about before either. You don't have any named faces. The only other remote possibility I can think of is if you have fiddled with the switched at Tools, Options, External References, Automatically generate names for referenced components. I had that off, but turned it on and it still worked correctly. Unless you are using some macro that rebuilds parts or features or replaces sketch entities, I can't think of a reason for this to happen.
Your reseller may be right. It is a simple thing to run a repair on your installation, making sure antivirus is off.
matt
Gianni Rondinini wrote in news: snipped-for-privacy@4ax.com:
Reply to
matt
hi matt. up to sp3 we didn't have that problem. everything was born with sp4.
one more nice thing is that we don't print "break lines" on drawings from sp4 on. it is nice (and funny) because it worked fine up to sp3 and was fixed in sp4 =)
i will look at it. thank you for this suggestion, too.
btw: where are you living? if you're next to las vegas, during august i'll offer you a beer ;)
regards,
Reply to
Gianni Rondinini

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.