Yasnak MX 2 control "CPU error" recovery

I am trying to fix a Mori MVJR CNC that had a "CPU Error" message on the screen.
I tried to restart it but the screen stayed black.
I set the switch to 4, restarted, and got the following messages:
"174 memory Error" (for about one second)
then after pressing the On button a second time:
280 Machine unready 204 OT 4 203 OT Z 202 OT Y 201 OT X
I have tried to reload the parameters but it does not accept any edits made to parameters above 7000.
The DGN page has all 0's
The lower half of the control is dead.
Has anyone been through this and know what is wrong? And what to do next?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@schmidtmotorworks.com wrote:

Jon, I have the same machine, but haven't had this specific error condition.
Couple suggestions. Sounds like a memory error on either the main cpu board or the memory board. Have you called Mori Seiki, or Yaskawa yet? They should be able to help you pinpoint the board that is causing the error.
The second start error is from the servo drives, suggestion no feedback from the limit switches. Probably because the memory error is causing the cpu to to get false limits values, or just zeros. Same with the DGN zeros, and the 7000 parameter problem. Probably all in the same memory location.
Does this machine have a 4th axis on it? And what do you mean by, the lower half of the control is dead? The lower half of the control panel, Jog, edit, xyz return switches etc...?
There are several places that will swap good boards for your bad ones, but you will need to figure out which one is bad.
ca
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.