Re: Close assy = CTD..just converted to 2k3

My guess is that this is a file corruption issue--one (or more) of your files is corrupted; when you remove the last instance of it from memory SW tries to close it out and bang-- CTD... It has to do with the way SW allocates memory for the particular offending feature.

The problem is likely to be in one of the parts, rather than the assembly. To find the source of the problem, open and then close parts (one at a time, with no assemblies open)--when you get to the right one, you'll CTD. You can expedite this process somewhat by opening and then closing progressively smaller sub-assemblies. If the offending part is in the sub, it will CTD too. Just remember that the trick is to only have one file open at a time.

When this happened to me, the problem was with the definition of a sketch in one of my parts--took me almost 3 months to track down which one. Once I found it, deleting the offending feature and redoing the sketch solved the problem.

FYI--it's a file corruption issue; it doesn't have anything to do with 2001 / 2003 per se--you just happened to corrupt one while converting. At the time it happened to me, SW theorized that the offending bit of data had been written to a bad byte on the hard drive. The big problem comes in that SW doesn't recognize that the file is corrupted--in my case there were no obvious issues with the part--no cherries, no messages, just CTD on close....

Good luck with your snipe hunt....

'mornin' all. > > We're finally making the jump to 2003 in the office, I've had it loaded > at home for a while and all seemed well. Last night I copied our working > files to a new folder and ran the Conversion Wizard on all 2500 someodd > files. > > I did this because yesterday I tried to open a 2K1 assy of about 75 > parts in 2K3 at work over the network and the software seemed to 'hang' > after about 30 minutes of what looked like no activity I killed it. I > could see the model, zoom, rotate, etc, but there was nothing in the > Tree and many of the Pulldown menu options were greyed out. Next to the > file name across the top was [viewing only], though I had that option > unchecked when I opened the file. > > Anyway, this morning I can open the Converted files and work on them > normally and all seems OK until I close the file, either with the 'X' in > the upper right corner or with File> Close..boom CTD. > > I'm running XP Pro, I just ran all the Windoze Updates, 1Gb ram, 1800XP > Athlon, Ti4400 videocard, tons of free space on the HD, not sure what > the swapfile size is (probably ~3Gb). > > Any suggestions on what to try to get this to work? >
Reply to
Loading thread data ...

Cool thanks for the reply! I tried opening a few of the sub-assys and parts inside the offending assy and they behaved properly, then I tried opening a higher assy with this assy as a sub, boom same CTD on Close.

I'll dig >

Reply to

Seems the problem was some welds in one assy file, it was the first and, luckily, last time I'd messed with them.

Michael wrote:

Reply to

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.