sketch only skeleton

I wish to have a part file that only has sketches in it to be the
driving skeleton file. But, when I start a new part file and insert the
skeleton part file in, the sketch doesn't come through.
If there a way to do this? A work around?
Aaron
Reply to
Aaron
Loading thread data ...
As a matter of fact there is. Since a sketch is 2D you can extrude a surface(s) from it and get access to the geometry. A kludge, YES. Does it work, sure.
Good candidate for an enhancement.
Aar> I wish to have a part file that only has sketches in it to be the
Reply to
TOP
Are you certain,.. I mean,.. that idea sounds so radical,.. surely nobody would need such functionality when we can WORKAROUND it wasting our time using a kludge!?!?!?!?!
.. ghawd!!!
Reply to
Paul Salvador
I'm sure you already know this but Solidworks would prefer for you to use an assembly as a bridge between part files when using one as a "layout". It's pretty effective. If all you want is the initial part's sketches as a starting point with no in-context relationships then go the assembly route, convert your entities, break the in-contexts and re-constrain from scratch. At that point, you no longer need the assembly. If you want the constrained sketches try copy paste with the desired sketch entities directly from the original part file into new part file with no assembly involved. If none of those things help, then the other workarounds, like extruded surfaces, are at your disposal :)
By the way, the extruded surface "workaround" isn't the worst thing in the world considering the options you have with changing each one's color, etc. That is a cool side effect and allows for color-coding your "skeletons". It might be worth thinking about.
- Eddy
Reply to
Eddy Hicks
Yeah, after I posted, I figured out that I can do it fromn the assembly. And I do need the in-context relationships.
thanks,
Aaron
Eddy Hicks wrote:
Reply to
Aaron
Well, it looks like I can't use the extrude surface solution. I get the error: 'The sketch cannot be used for a feature because an endpoint is wrongly shared by multiple entities"
That error drives me nuts and I see it as a severe limitation of SW sketcher. Why can't I have multiple line sharing endpoints??? It's just absurd
ok.. I just retried it first using the the contour Select tool, and it worked...well sort of. If I selected the whole sketch, it crashes SW. If I do part of the sketch and then go back and add the rest it worked.
Doesn't seem too stable.
Aaron
T> As a matter of fact there is. Since a sketch is 2D you can extrude a
Reply to
Aaron
Usually what that error message means is that you have two lines or curves on top of one another, so one is hidden under the other. SW doesn't have a problem with multiple lines sharing endpoints. It has a problem with ambiguous contours.
That makes is sound like I was right and you have a hidden entity that was causing the extrude to fail.
Ed Eaton cautions folks to stay away from the Contour Select Tool because it isn't too terribly stable. Anything that requires the user to pick in the graphics area seems to be easy to confuse. My own nemesis is Mutual Trim of Surfaces.
Jerry Steiger Tripod Data Systems "take the garbage out, dear"
Reply to
Jerry Steiger

Site Timeline

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.