Sketch zero-length entity

I am trying to do a basic extrude following the tutorial. i create my
sketch and continue to the extrude properties and i don't get any
preview and when i click ok on that screen i get an error message saying
"The sketch contains a zero-length entity"
im using 2006, any ideas?
Reply to
Bob Marley
Loading thread data ...
usually this means that you have a line (or other geometry) in which the end points are on top of each other -- in otherwords you cannot have a line between two points that are on top of each other - you can only have a point. This can happen when changing dimensions in a sketch which might cause other geometry to become (zero length). A diagnostic tool can help you find the offending geometry. Go to
Insert --> Sketch tools --> check sketch for feature. Then click ok -- get the same error -- click OK on the error -- Move the check sketch dialog box out of the way. You will notice geometry highilghted in green -- zoom in to all the endpoints of that geometry to see what the problem might be (as the problem may not be the acual highligted geometry, but rather the surrounding geometry).
I hope this helps Thanks Steve T.
Reply to
Steve Tietz
This error often comes up if the sketch contains tangents. ie a curve joined to a sraight line where the curve is also positioned at a tangent to the line.
Steve Tietz wrote:
Reply to
Olly183
i don't have any of that, i just drew a rectangle using the origin as one of the points. when i run the check sketch it highlites the lower line green. i even went as far as deleting the line and redrawing it, no good.
Reply to
Bob Marley
anyone else have a suggestion, so far nothing has worked.
Reply to
Bob Marley
Is this happening in an file that is existing, or just in any new file when you try and extrusion? If when you do that check sketch for feature, and it high lights something in green, then there is something that is overlapping that needs to be deleted. You can always choose the contuor select optiona dn then just choose the contour you would liek to use.
Reply to
modelsin3d
its with a brand new file. i draw a circle and thats all i do in the sketch and i still get the same error. the only other object on the page is the origin.
Reply to
Bob Marley
If this is happening with a brand new file, meaning you start a new part from File > New or the New icon, then it could be that you've got something hosed in your template. If there is a sketch already in your part template, then delete the sketch from the feature manager, save this edited version as your part template, and try again.
If your template doesn't have an existing sketch, and this is happening from a new part, I would uninstall SW, clear out your SW registry and reinstall.
Otherwise, if this is on some part you've been working on, you might try to drag boxes around the endpoints (drag left to right) and see if something gets selected that you can delete.
Zero length sketch problems are among the most frustrating to me personally because when you've got one (or several), you can't do much with your sketch until you fix all of them. If you have two and only delete one, it will tell you the sketch is unsolvable and put it back to its prior condition (with two problems instead of one). When this happens, I just blow away the whole sketch unless it's fairly complicated or difficult to recreate.
A lot of times beginning users who haven't quite picked up the knack of sketching in SolidWorks run into this problem, starting and ending a line or arc at the same point.
Anyway, good luck.
Matt
Reply to
matt

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.