RCX 2.0 USB tower problem

I have a nice fast Windows XP and all looks fine except I can't use the USB
Tower.... it connects to PC ok, I can view info/diagnostics which say its OK
from the Control Panel (the drivers installed ok - though they are from 2001
?). But if I use the RIS 2.0 or BRICX (latest) - when configuring the Tower
it freezes my machine totally. Screen freezes, cant do COntrol Alt Delete or
anything, basically hit the reboot switch on front of the box. I have tried
everything including unplugging all other COM's and USB devices
(printer/scanner) to no avail.
I have surfed the next for a updated XP driver and can't find anything ?
Anyone else had this problem and fixed it....
PS: my daughters machine has Win98se and works fine - though I would prefer
to use my office machine.
Reply to
Michael L
Loading thread data ...
I have exactly the same problem.
Lego support was of NO USE AT ALL. I only talked to people which had less knowledge than myself. Im quite angry at that company.
Reply to
Janick
I have the same problem too. Have you had any resolution?
I have a Dell 266 MHz (years old), with Windows 2000, that runs the tower fine, just very slowly because it's 266MHz.
I have a new 3.0 GHz Pentium 4, Windows XP, sp2, that freezes as soon as the Mindstorm software tries to access the tower. A windows Server 2003 OS on same machine did same thing.
Driver in control panel says status is OK.
Motherboard is Intel 915GAG. I haven't found any USB drivers for that motherboard (other than what comes with OS and/or BIOS). BIOS is up to date.
Reply to
a_schweitzer
Fixed! yay yay yay.
A very helpful person out there sent me a link to a driver update on the lego site that I downloaded, installed, and it fixed the problem:
formatting link
Apparently the problem is related to the hyperthreading supported by the processor.
PS, after I installed, the system immeidately stopped freezing. However, I did discover that if I "Alt-tabbed" away from lego while it was first connecting, it the lego program went out to lunch. If I just had some patienence and didn't touch anything, it works great --- I haven't tried Al+tab again, so I don't know if the same thing happens at other points.
Reply to
Andrew

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.