Q about Interactive C and Talrik 2

I am building Talrik 2 and using Interactive C to program it. The processor used is Motorola 68HC11. All my connections are working
right (physical connections to the robot). I tried to download the compiler pcode_hb.s19 file using the HBDL downloader on com1 port. It gave me a Config register error even though my config register was set to 0x0c as specified in every IC manual. It then worked with the register set to 0x80, but then when I tried to make IC work it gave me an error saying my board is not connected. I thought the problem might have to do with my com 3 port being used (hardware conflict on the interrupt), so I disabled it. I still have the same problem. It would be great if someone could help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.