Adding this part into this assembly would create conflict of references. Cannot add. ?

WHY, ok, I get this error message when inserting a part into an assembly,
"Adding this part into this assembly would create conflict of
references. Cannot add."
SO I break all the exterenal refs. in the part, try to insert into an assembly but get the same error.
I usually have good troubleshooting skill, but this one has left me clueless. HELP, anyone? SW2007
Some notes, the asembly is a save as copy assembly that was top down designed, lots of references to the assembly, the file names are all the same as before but just a different location and are being re- assemblied into another same name assembly. The now broken refs in the parts refer to the same name assembly but can't be inserted into it, the error above results.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Joe Sloppy wrote:

There is still something that has external references to it, most likely a sketch plane or extrude/cut to surface or face. Perhaps the best thing would be to use SWExplorer and rename the parts/assembly to something different and then you can bring this renamed assy into the new assembly. Or something we do on occasion is to parasolid out the assembly, then create a new assembly from this assembly if it just for reference positioning.
-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Joe Sloppy wrote:

Sigh...
Get Banquer to tgell you whats wrong. Of course its the multiple contexts switch.
Good move, yuou broke all the references. Banquer really is advising you , I see.
The error you quote means that the part already has a reference to an assembly of the same name as the one you're putting it into. The way to fix it is not to break reference, but to really remove the reference. So whatever way the reference was created, like an incontext sketch or something, you need to delete the reference itself. Breaking references is like puttong fresh dog shit on a wound. You can't see the wound anymore, and it looks better, but in time it will become infected and festering.
Another way to fix it is to change the name of the assembly, but that just adds chocolate springkles to the fresh dog shit in the wound.
Sometimes this can be caused if you try to put a part with incontext references into an assembly that is not yet saved, because the assembly has the temp name of Assem1.
Or you might try using the multiple context switch. Ask bongquerr where to find it. That't llike putting chocolate syrup on the springkles on the fresh dog shit.
Daisy.
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

FIXED, Breaking the references did nothing as said, what fixed it was when I changed the feature that had the references (extrude to surface (x)) to (blind), (deleting would have removed it too), so no references now, and then I can insert the part now and re- references it in the same name assembly. Thanks for the tip. I did try help first but no luck in finding that error messages. Did I miss that too?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Probaly not. SW doesn't believe their software gives errors, so they never list them in the help. Not that the help really helps much.
Daisy.
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to ChamberPot, 8Moshe8 wrote: Thank you, I am new to SW and had the same issue Because I used the Cavity function. Saving the assembly with a new name before adding the problematic parts resolved the issue. Some times it is hard to break every reference due to the added complexity so I save the parts while breaking the references.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.