Harrison M300 lathe ........

Hi
Having to correct some parts of my last posting.
I have a Harrison M300 lathe in my garage.
Having serious problems with the Feed gears ("ABC", "RST", "WXY");
as they do not engage. Does anyone have experience this ? I get no 'feel' whatever when turning the "RST" knob.
While trying to see if I could do anything, I took off the "WXY" knob intending to try and loosen the spindle. The ball end of my alen key snapped off in the head of one of the bolts. I do not want to drill it out, but all my efforts to get the broken piece out have failed.
I am totally deaf, so my list of contacts is very small. Can anyone advise me ?
I am in the Reading area (RG2 8JP).
cheers
*** Free account sponsored by SecureIX.com *** *** Encrypt your Internet usage with a free VPN account from http://www.SecureIX.com ***
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi
I have a Harrison M300 lathe in my garage.
Having serious problems with the Feed gears ("RST", "UVW", "XYZ"); some do not engage. Does anyone have experience this ?
While trying to see if I could do anything, I took off the knob attempting to take out the spindle. The ball end of my alen key snapped off in the head of one of the bolts. I do not want to drill it out, but all my efforts to get the broken piece out have failed.
Can anyone advise me ?
I am in the Reading area (RG2 8JP)
cheers *** Free account sponsored by SecureIX.com *** *** Encrypt your Internet usage with a free VPN account from http://www.SecureIX.com ***
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.