Problem with Spectrum Consolidation under DCC

Hi all
I have two Bachmann Spectrum 2-8-0 Consolidations. Both came DCC ready.
One is addressed as 61 and the other as 19. After about 2 months of
intermittent use, one of them failed to respond.
I have tried reprogramming but the controller is getting no response
from the chip.
Today, I stripped it down to check all of the connections. Everything
seems OK so I put it back onto the layout. I tried addressing at at 19
and got nothing. I addressed the other loco at 61 and off that went'
However, al of a sudden, the faulty one started to move. I shut the
throttle down and tried agian.Once more I have nothing happening.
Has anypne any thoughts as to what I might try next and, more
interestingly, why it suddenly started even when not addressed.
Any hwlp would be gratefully accepted.
David
Reply to
David Pennington
Loading thread data ...
At a guess I would say that the settings in the one decoder got "glitched". Best fix is to place it on your dedicated programming track and do a full reset the the decoder default settings, and start reprogramming from there.
Reply to
Rick Jones
You've got a fried controller module in the loco. Electronics does have a early failure rate and the world of model trains isn't exactly a benighn enviroment for electronics. Replace the module with another and hopefully that one will last longer.
-- Bob May
rmay at nethere.com http: slash /nav.to slash bobmay http: slash /bobmay dot astronomy.net
Reply to
Bob May
David I would suggest first you set the decoder back to factory default and see if it works. If that doesn't fix the problem, send the decoder back to the manufacturer. TCS and Digitrax have no-fault one year warranties with proof of purchase. Good luck Mike M
Reply to
mike mueller
Firstly though, try readin the full decoder on your programming track - Decoder Pro is good here.
Steve Magee Newcastle NSW Australia
Reply to
Steve
Tried resetting but the chip wasn't responding. I was hoping not to have to replace the chip but I looked at the breadown diagram in the box and saw that it was an 8 pin NMRA plug so I did a chip swap out. First replacement Bachmann chip didn't work either but the next one did. I am now up and running again.
Thanks for the suggestions. David
Reply to
David Pennington
Though you have solved the issue, you might consider the Bachmann forums which are quite active. By the way, DCC READY means no decoder but ready for a decoder. DCC ON BOARD means a decoder is in the loco. Also, CHIPS are on the decoder.
formatting link
r
Reply to
Rich

Site Timeline

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.