Lincoln ranger 8 suddenly stop welding

This ranger 8 was working good, I stop welding for a moment then begin to weld again the engine rev up but all I am getting is a spark like striking a match I
get AC power but very low. any suggestion to solve the problem would be appreciated
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to Ewart G Hall, njavier520 wrote: Hi, did you get the problem resolved? I have the same problem and need help with it too..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to Ewart G Hall, njavier520 wrote: Hi, did you get the problem resolved? I have the same problem and need help with it too..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to njavier520, hobbywelder wrote: My ranger 8 is doing the same, low power on 110 and on the welding side. Any suggestions are appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to njavier520, hobbywelder wrote: My ranger 8 is doing the same, low power on 110 and on the welding side. Any suggestions are appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.