G19 different for Fanuc?

I've used G17,18,19 on several controls... They all act exactly like I expect, and all exactly the same.... Until I get to this Robodrill/Fanuc 31iA5.
Anyway, I always used G17,18,19 to specify the plane for the circular interpolation. Just like the books describe. This has worked exactly as I expected on Bendix/Autocon controls, Bostomatic, Acramatic 2100, Siemens, etc. Even the examples on line, and in the Smid books.. I specify G19 if I need to interpolate an arc in the YZ plane, and none of my coordinates are affected. All the G00, G01, G02, G03 moves specify the points just like I see them in my work coordinates, and if I need to make an arc in any plane, I set the G17,18,19 as needed.
I have never seen the G19 change my work cordinates on any other controller before.
On the Robodrill with the 31i A5, setting the G19 , then a G43 makes my work coordinates go WHaCkY !! X,Y, and Z coordinates all change when I invoke the G43, if G19 is set, then go back to normal with a G49. WTF ????
Didn't use G19 before on this machine, but didn't expect anthing different.
Single stepping the program, it takes off trying to plunge into the part, and through the vise, even though the move is to Z .8 ( above the part) (NO, it didn't crash.. But it Wanted to.)
Why would the G19 + G43 make the entire work coordinate sytem go haywire?
I tried changing the G19 to a G17, and everthing was perfect, it knew exactly where the work coordinates were, went exactly to the right spot on the part, everthing is beautiful... Except it can't do the G03 move, since it now complains about the G03 being out of plane...
I know it needs a G19 to make the G03 move, but the G19 completely messes up the work coordinate system, and tries to shove the spindle somewhere below the table, acoording to the distance to go.
Any ideas? Is there some magic paramters? Or is this just a symptom of a really screwy bug?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

That's very bizarre. I've used G19 on a 16i and 16MA before with no problems at all.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's a strange one, for sure. Did I describe that adequetely?
Thanks for confirming that it ~Should~ have worked.
There were some other REALLY STRaNgE things in this control before, too. Like going into edit, and searchig for T10, it would dump the whole control. Fanuc was totally stumped, gave up, and loaded in a new revison operating system.. Thus making whatever the problem was, act, well different....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Half-nutz wrote:

There certainly are some reported bugs in this control's software; but what you're seeing MIGHT be an actual feature. The control (I think) is smart enough that it can change the whole world it lives in when planes get switched around. G43/44, for example, normally act only on Z, because most 3 axis controls live normally in the XY plane. On newer controls, though, it's possible to have G43/44 act on WHATEVER axis is not in the designated plane. It sounds like that's what's happening to you.
If that's the case, you should be able to put in some nice round coordinate commands, and a nice round offset value, and see them all behave as if the G43/44 were assigned to X, when you call G19. And the offset might also show up in Y when you call G18. If that works, then you'll just need to find the parameter that turns this feature off. Be thorough, though. There could be other features that go with this, that all have to be set/reset together.
If you can't make it behave in SOME predictable way, however, then you'd better start documenting everything that happens, and start talking with Fanuc about the next version of software.
Good news is, the iron and the control both have the same brand name on them, so you won't have to worry about two service companies pointing fingers at each other and leaving you in the middle.
Please keep us updated. This (unfortunately for you) could be interesting.
KG
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Half-nutz wrote:

It just occured to me that my earlier post didn't answer your question directly. Fanuc generally doesn't do anything different with G17, G18, or G19, than what you've seen on other controls. In fact, those others actually use what Fanuc originated for plane selection techniques, many years ago. The one you're working with is definitely acting outside the box. The only question is whether it's supposed to, and how you can get it back in the box before it bites you.
KG
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks guys..
Tried some more stuff, and if I set G19 -Before- the tool change, it goes screwy...
G19;
(M06 macro) ; G49 ; M06 T#20 ; G43 H#20 ; ( cordinates go screwy here ) return
Now... If I do a G17 first..
G17;
(M06 macro) ; G49 ; M06 T#20 ; G43 H#20 ( coordinates are fine here ); return
G19 ( Coordinates are still fine here ) ;
Do I need to do a G17 before a tool change??? And do the G19 AFTER the tool change, and after the G43??
That doesn't seem like standard practice, to me.
AND it seems like something ELSE that I found screwy in that control (so far).
Any other thoughts?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Half-nutz wrote:

It sounds like the MTB hasn't properly set the parameters in the control. All of this behavior is configurable through the parameters.
--

John R. Carroll
www.machiningsolution.com
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mar 11, 10:17am, "John R. Carroll"

Thanks for the replies. The dealer called, and told me that yes, I Must set G17 before a tool change.
It seems strange that it is OK until I do a G43 after the tool change.. That is what makes it go screwy...
Setting a G19 after the G43 seesm to be OK. G43 with G19 set goes BAD.
Interresting how Fanuc can bite you in the transom. Too spoiled with the A2100's.
Thanks guys.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Pete,
Suggest reset machine parameter to specify g43 as default and then insteaad of using G43 / g44 simply use G00G91G28H00 to cancel lentht , (and G90 Hxxx to initiate your new length just after tool change )
Also maybe consider posting some code snippets here guessing possibly something simple so easy to get frustrated and overlook something...
--



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.