Wildfire 4 + moldbase extension EMX

Hello,
I'm currently designing plastic molds with WF3+EMX4.1. (I haven't quite accepted the quite different EMX5.0 , but
maybe that will change once I learn it) Recently I decided to see what had happened in WF4 and maybe change over to WF4. I also tried to start the EMX but I couldn't get either version to run. I got some error message about 'legacy option not set', or something like that.
Isn't WF4 compatible with the existing EMX versions?
/Bjorn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Whether EMX4.1 is compatible with WF4 or not, getting a "trial" version of software to run involves some nontrivial installation and licensing problems. Included in these problems is the question of whether it's possible to run addons, like EMX, on two different versions of the software and to be called by two different license packs. All in all, though, this does sound like a licensing issue requiring special knowledge to set up. Maybe someone here has that knowledge (and the time to help). But, if it were my problem, I'd be getting hold of PTC.
David Janes
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

We are on a support contract and I have recently recieved and updated my licensefiles from PTC. As far as I can see I have installed the licens correct.
Changing from EMX4.1 to EMX5.0 is just a matter of changing a line in the config.pro and works fine with WF3.
I have put this question to the reseller, but that was a couple of weeks ago so I thought I should try my luck here.
The correct complete errors during startup are
--> std.out Features Obtained: PROE_FoundationAdv Pro/MOLDDESIGN-2 Mechanism_Design Import_Data_Doctor Expert_Moldbase Pro/SURFACE Pro/DIEFACE Pro/ASSEMBLY Pro/CASTING Features Not Obtained: Pro/EXPERT-MACHINE_SET <-- we ended support for this at WF2 Pro/TOOLKIT application 'EMX 5.0', from registry file 'C:\ptc\emx5.0\text\protk.dat', predates Pro/ENGINEER Wildfire v4.0 but was not marked as using legacy encoding.
(or Pro/TOOLKIT application 'EMX 4.1 M180', from registry file 'C:\ptc\emx4.1\text\protk.dat', predates Pro/ENGINEER Wildfire v4.0 but was not marked as using legacy encoding. for EMX4.1)
--> support.inf (some private info removed) FILE: support.inf.3 TIME: 02-May-08 12:12:10
=================================================License Information ================================================Service Contract Number: Release: Wildfire 4.0 Pro/ENGINEER Date Code: M010 License Name: PROE_FoundationAdv License Version: 25.0 License Type: Commercial version, Floating License Server Name:
License file search path: 7788@server;
=================================================Configured Option Modules ================================================The following Pro/ENGINEER options are installed: (Note: license extensions are marked with a '*')
Design_Animation Pro/DATA_for_PDGS Pro/LIBRARYACCESS Expert_Moldbase* Pro/DETAIL Pro/MOLDDESIGN-2* Import_Data_Doctor Pro/DIEFACE* Pro/PHOTORENDER Mechanism_Design* Pro/ECAD Pro/PLOT ModelCHECK Pro/FEATURE Pro/REPORT Pro/4DNavigator Pro/INTERFACE Pro/SCAN_TOOLS Pro/ASSEMBLY* Pro/INTF-CADDS5 Pro/SHEETMTL-DES Pro/ASSY_PERFORMANCE Pro/INTF-for-CAT Pro/SURFACE Pro/CASTING* Pro/INTF_for_STEP Pro/WELDING Pro/CDT Pro/LEGACY Pro/Web.Publish
=================================================Machine Information ================================================Host Name: User Name: Host ID:
Pro/ENGINEER Machine Type: I486_NT Pro/ENGINEER Graphics Type: OPENGL Using hardware accelerated OpenGL.
OS Name: Windows NT OS Release: 5.1 OS Version: 2600 Hardware Type: x86 Family 6 Model 15 Stepping 6 GenuineIntel 2400 MHz
=================================================Installation Directories and Command Information ================================================Directories:
Pro/ENGINEER Installation Directory: C:\ptc\proewildfire4\ Pro/ENGINEER Startup Directory: C:\ptc\startwf4\ Pro/APPLICATION MANAGER Directory: Not Available Pro/INTRALINK Directory: Not Available Commands:
Pro/ENGINEER Start-up Command: C:\ptc\proewildfire4\bin\proe.exe =================================================Configuration Information ================================================Configuration files read:
C:\ptc\startwf4\config.pro C:\ptc\startwf4\config.win.11 C:\ptc\proewildfire4\text\menu_def.pro
Pro/HELP Search Path: C:\ptc\proewildfire4 =================================================Auxiliary application Information ================================================Application 0: EMX 5.0 Exec path: C:\ptc\emx5.0\i486_nt\emx50.dll Text path: C:\ptc\emx5.0 Version 26 - 2004150 Application is not running.
CONTACTING TECHNICAL SUPPORT
For information on contacting PTC Technical Support, please refer to the printed Customer Service Guide or the on-line edition at:
http://www.ptc.com/support/support.htm
(Click "Contacting Technical Support")
/Bjorn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

=================================================> License Information

=================================================>

=================================================> Configured Option Modules

=================================================>

=================================================> Machine Information

=================================================>

=================================================> Installation Directories and Command Information

=================================================>

=================================================> Configuration Information

=================================================>

=================================================> Auxiliary application Information

=================================================>

A couple of things are confusing me about what you've done. You say EMX5 works with WF3 but not WF4. That sounds, to me, like you've got both versions of Wildfire installed. Is that the case? It also sounds like you've had both versions of EMX installed before installing WF4. Something to do with PTK sounds like it needs to be installed (maybe by installing EMX5 after installing WF4) because it's erroring the protk.dat file. You've said that getting EMX to run is a simple matter of changing a config option ('pro_something_dir'?) but the license file lists EMX50.DLL under Auxilliary Apps which are started typically by going to 'Tools>Aux Apps' and checking off the Mold Design Ext application. Is this how you're trying to launch it and where you're getting the error? I'd go back to the WF4 installation disk and make sure there wasn't some component, some innocuous little check box, that needed to be ckecked/installed for EMX to work on WF4. I'd also remove any traces of WF3 before starting. Then I'd do the 'Tools>Aux Apps' business and check to see if the protk.dat was recompiled. If not, maybe try to reinstall EMX 5 upgrade.
David Janes
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.