PIC refusing to program

Hi all,
I have been using a PIC16F628 for a project, programming it fairly often
(only for a few days though) and it has been working fine. It seemed to be
misbehaving so I erased it, and now I can't program it again! This has
happened before with a 16F84 but I can't remember how I fixed it.
I am using a programmer from oatley electronics which uses the parallel
port, and David Tait's FPP software which reports "Failed to program code!"
or "Failed to program config!". I think once I get the config programmed it
will work but for now it wont do anything (code protected or something?).
Reading the PIC, it won't tell me what the config workd currently is. I have
tried other software too but it was hard to tell if it was set up properly
because it was refusing to program anyway.
I have checked all the pins with an oscilloscope while programming and they
are doing what they are supposed to, though the rising edges of clock and
data are rather rounded. I haven't changed anything though, so I doubt that
is the problem.
Any ideas would be much appreciated!
- Daniel
Reply to
Daniel Watman
Loading thread data ...
Hmmm. Just a thought.... It sounds like you may be having trouble with your voltage regulator. Have you checked its output under load?
BRW
Reply to
Bennet Williams

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.