Got a problem with an Aztek A430. The trigger on top doesn't seem to move the plunger inside the body when it's pulled back, but the plunger will move against spring resistance if pushed back by a rod inserted from the front, with the nozzle removed. Can't get any flow at the nozzle tip.

Anybody else encountered this?

I've tried emailing Testor's, but heard nothing from them.

TIA Jimi

Reply to
Loading thread data ...

Great brush with three size tips. Easy to clean, just don't bend the needle or tip.

Can't get a hairline out of it though; I'm going for the Iwata Micron next! Cheers,

The Keeper (of too much crap)

Reply to

G'day Went back to Testors website, reset IE security settings to defaults, and sent another email. Got an email reply from them almost instantly, allowing for the time difference.

Their email suggested a few possible remedies, all of which I've already tried, so it looks like the airbrush is going back to meet it's maker.

Thanks for the replies.

Reply to

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.