DCC Bus Rail and wiring.

Got a bit of a wiring problem to solve, and not quite sure how to address this, so if anyone can help would be greatly appreciated.
Using DCC Block Detection on my layout along with a DCC signal decoder for electric signals, the manual recommends powering and opertating the signals on a different power bus or power supply, so if there is a short or derailment the signals stay lit and correctly set.
To wire this, the outer running rail, is powered by the DCC controller, the inner rail is fed by the sensor wire from the signal, so when the train is in the isolated block, it trips the signal.
If I feed the outer running rail by the DCC controller directly then put the controller wires through the booster to give me a second district/isolated section, and run accessories and signals from that, the sensor from the signals is now feeding the voltage from with inside the power booster district/isolated section, this means the rails themselves are fed by one wire from outside the power booster, and the other inner rail from within the power booster district. The end result, is the accessories run fine, but the trains dont move.
The signal has a PWR and RET connection which are in effect voltage and DCC signals, the signal decoder also has D1 and D2 which are DCC power/DCC signals.
Can I run the RET wire on the block detection (to give the train the missing other inner rail voltage) back tot the controller outside the booster block and still expect it to work. Being a bit new at all this, am unsure how to get the two bits seperate so that the signals work and the train, but if the train derails / shorts, the signals still function.
--
Chris King
(remove nospam to email direct)
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Please be more specific as to what products you are using.

What sort of DCC controller are you using?

What sort of booster are you using? Both tracks need to be fed from the same booster.

It sounds like the detection for the signals is inextricably linked with the DCC signal so powering them separately will be difficult/ impossible.
The usual problem is with point decoders where a short circuit from running the wrong way into a set of points cuts the power. If the point decoder and point motors are powered from a separate booster (or you can use block cut-outs) then you can still change the points and fix the short. Otherwise you need to use the hand of good to push the loco back.
Why do you need the signals to work correctly in the event of a fault?
MBQ
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.