legOS/brickOS: a despairing cry for help!

Has anyone recently built legOS or installed winlegOS under windows? If
so please mention which route/version you have used.
So far I tried:-
1. winlegOS: Installs but fails to build Demo (or anything else)
without a useful explanation:-
c:/tools/winlegos/util/makelx helloworld.ds1 helloworld.ds2
usage: /tools/winlegos/util/makelx.exe file.ds1 file.ds2 file.lx
make.exe: *** [helloworld.lx] Error 1
(The .ds1 and .ds2 files are present)
2. Full 110 MB cygwin install, cross-compiler build as described @
sourceforge (brickOS Instructions for installing on
Win9x/NT/2000/XP). But Building GCC ( I get:-
install: g++.exe does not exist
chmod: cannot access `/usr/local/bin/g++.exe': No such file or
the only g++.exe I see is in /bin - did I do something wrong?
3. I also tried loading a prebuilt H8 cross compiler and latest brickos
(0.9.0) but:-
/usr/local/crossgcc/h8300-hitachi-hms/bin/h8300-hms-gcc -O2 ... -c
printf.c -o printf.o
printf.c:25: stdarg.h: No such file or directory
(cygwin configuration is such fun:)
Reply to
Loading thread data ...
LeOS has been superceded by the newer brickOS technology. There is a simple package you can download that installs the minimum cygwin components to use with with the Brickx Command Center IDE for using Java,C, NQC and other languages. and the brickOS firmware as well as others. You will find this a handy tool to use with the RCX, and things should be easier to configure.
formatting link
For minimal cygwin download look for link:
"minimal brickOS and leJOS for BricxCC "
Reply to
Dale Stewart
Thanks - looks promising - but I have obviously got very fat thumbs as I am now stuck on BricxCCSetupCygwin.exe. It prompts "Select install disk" looking for file "BricxCCSetupCygwin.002" - which is nowhere to be seen!
Reply to
On further investigation I found that the .exe was corrupt!
It seems there is something quirky about my downloading from sourceforge. Both Firefox and IE truncated the file at 11.8MB the first time I re-tried it (from two different machines).
Reply to
For what it's worth, I have experienced the same exact problem with Sourceforge, only with different files. Wish I could offer real help. Maybe someone on this group has a download they would be happy to share with you ?
Reply to
I was actually having trouble tonight downloading some files from sourceforge using IE. What finally worked was using Mozilla browser. Got everything just fine. Hope that helps !
Reply to

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.