model tree displays incorrect model

Guys,
rel 2001. I have a drawing which uses multiple models, an assembly and some
parts. No matter which model I select to be current, the model tree always
displays the model of the last view entered on the drawing, which happens to
be a part. Is this intended functionality? How can I get it to show the
assembly model tree?
Also, the sheet number box has become greyed-out so I cannot select which
sheet I want to be in, I have to go into Menu/Sheets/Set current. Any ideas
why?
Dave
Reply to
dakeb
Loading thread data ...
Guy Lagiere came up with: View, Model Tree Setup, Switch View and it worked fine.
Restarting ProE seems to have cleared the greyed out sheet number too. I suspect an open mapkey causes it.
Reply to
dakeb
I used to get this problem with greyed out sheet number in 2001. Usually, clicking on the 'Make Window Current' button in the toolbar cleared that and made the sheet number active again.
Never worked with multiple-model drawings in 2001. In Wildfire the tree seems to periodically switch to other model than the one it was previously pointed to, all by itself. In WF all you need to do is right-click on one of the views of the model you want to see in the tree and choose 'Show Model in Tree' (or something like that - I don't have Pro/E in front of me right now) from the RMB menu.
Reply to
Alex Sh.
What you're looking for is in the under "View" in you drawing menu. Got to Views...Dwg Models...Set Model. This allows to set which model (in a multi-model drawing) you are creating views for. Whichever is current will display at the bottom of you screen. You can also use this area of the menu to add and delete other models from the drawing.
The sheet control at the top greys out if you're in the middle of a command. Making the window current clears everything and you should see page numbers (as long as you have more than one). An alternative to this (if you want to switch sheets) is to use the Next and Previous command under the Sheets menu.
Warren
Reply to
Warren Ginn
Thanks Warren, see below.
No, that doesn't change the model displayed in the model tree. It seems the model tree can display a different model to the one listed at the bottom of the screen.
As earlier answers said, you have to go into the model tree, and select Tree/Switch view, and click on a view which contains the model you want to display in the tree.
I would prefer it to work the way you said, but it doesn't.
Making the current window active doesn't clear it for me. I suspect there is a faulty mapkey that isn't closing down properly. I have to use the menu manager to switch sheets.
Reply to
dakeb

Site Timeline

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.