Break Lines...

I've got a issue with "break lines" on dimensions that have bothered me on and off for a long while and I figured I finally would break down and ask.
Are they just quirky with when they decide to break or is it just me? I'm on SWx 2007, but have had this happen on previous releases. I'll have 20 dimensions that are inserted on a drawing, lets say. I adjust all dims to final location, make sure they've got tolerances, move and adjust some more, etc. The last thing I do is go through individually and turn on certain dimensions break lines, for whether I want the vertical dimensions to break the horizontal or visa-versa. I'll get through 95% of the dims I want with break lines and then I'll get a "stubborn" dim that just doesn't want to cooperate. If I give up on it, it looks like I forgot to do one when you view the print. My standard is that when this happens, I'll just turn off all break lines so that at least the drawing is consistent.
Does anyone else have an idea on what causes this? All dimensions were created at the same time, and have identical settings that I can tell. I've tried yelling at it to try to tell the dim to get with the program, but this seems to have no effect other than to get strange looks from other coworkers. Was going to try kicking the PC next in a effort to wake it up, but figured I'd ask here first. :-p
IYM
PS: Forgive me for not googling to see if this has been discussed before, but as internet usage is monitored here, I try to stay off and stick to the NNTP news port in my reader as it's not looked at.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have seen them not break properly if the item they cross isn't an actual dimension witness line. Could that be your issue as well?
WT
<IYM> wrote in message > I've got a issue with "break lines" on dimensions that have bothered me on

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Wayne,
No - I'm aware that (for whatever reason) that certain items, (such as notes/annotations) are "immune" to the breaking features. These are your standard dimensions. I create a drawing view, bring in the dimensions and move them around and you get one or two that are a PITA. It does not seem to matter whether any of the dims are reference not, you seem to get the same random result. Obviously, the more dimensions you have on the print, the more chances of it happening are. If you create simple parts with 3 to 10 dims, you may not ever have an issue. My current print is a fairly simple turning blank print and has 50 dims on it and I have 2 "bad" dims that I want to smack around for mis-behaving.
Now after thinking about it last night, it seems to be random - however - I'm wondering if this can be an anomaly based on how the model was created. What I mean is that on a few previous releases, there was an issue of dimensions on your print "disappearing" if you had edited a revolved feature model. If you made a change to the sketch in a revolved feature, then exited the sketch, saved and returned to the drawing, dimensions imported from that sketch would seemingly disappear. The correction quirk was to go back to the part, edit the sketch again and exit the sketch not by closing out normally, but by clicking rebuild. Do that and return to the print and presto - your dims were back. I mention this because as a lot of my prints with issues have revolved features (as in turnings) instead of building them out of circular stacked extrusions and cuts. Perhaps this might be another issue regarding dims and revolved features. Just a thought....Guess I could try doing models out of stacked extrusions, but I'd hate to do that. A lot more work, more features and more difficulty in editing in a later assembly...
Anyway, just a stab in the dark...
Thanks for the insight, though...
IYM

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I only recently saw the break lines option, thru reading the SW Bible and I thought this was really neat. For finicky prints I do the break manually - PITA. However, the option hasn't worked on any of the drawings I've made, either with inserted dimensions or dimensions created in the drawing. I'm running 2007 sp2.2.
I've checked the options settings, tried dragging the dims around a bit, rebuilt multiple times and tried using the break option on one, then the other, then both dimensions. Nothing works yet. There also doesn't seem to be much in the help files
Any suggestions?
Diego
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

lacking. I've put in one ER for break lines already, by may need many more before they fix their functionality.
Matt Lorono http://sw.fcsuper.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The only thing I can add, is that you have to be careful when using the break line feature. If you simply create the drawing and dims, then window to select all dims and turn the break line feature on, it will probably give you the result you have....Nothing. Similar to adding fillets on a part model, using the break line feature has to be done a particular way to get the result you want. Generally, it's one of the last things I do upon completing a drawing. After all dims are in, I'll start selecting one dim at a time (or a series - i.e., all horizontal dims that I know I want to break) and turn the feature on. It also is tricky in that it'll break lines based on the order you activate the feature. (I'll use the term "jump" as it's easier to think out and type "break line"..besides, that's what we used to call it when you drew by hand and instead of leaving a gap, you drew the extension line actually jumping the other extension line.) Anyway, for example, on a left side of a view, lets say you have three horizontal dims, and a radii as well as a chamfer dim that cross all three horizontal extension lines. If you turn on the break line feature of only one of the horizontals, that single horizontal will jump the radii and chamfer. If you then turn on the break line of the radii, it'll jump the extension lines of the two remaining horizontals. Now say after that, you turn on the break lines of one of the remaining horizontal dims and because the radii break feature was activated before, the horizontal's extension line will remain solid and jumped by the radii, but will then jump the chamfer. The result will be a bunch of inconsistent breaks and probably not what you had intended. In order to fix it, you have to deactivate and activate the break lines in the order you want.
Kind of a PITA but once you get the hang of doing it, it'll come second nature and you can usually read ahead to get it done in the right order the first time...
Sorry, but this is the best way I can describe the Break Line feature....
Good Luck!
IYM

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Same problem here on 2007sp3.1 (and earlier ones too). It usually works if you toggle it on and off a few times, move the dim around and do a few rebuilds. It all adds to the enjoyment of this oh-so-reliable product.
John H
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.