Installation issue. Advice requested.

I'm having some difficulty with an installation. The same issue has been
verified on 2006 and 2007 installs. It's "seems" to be a software
conflict on the local machine, but I'm not sure where to look and am
hoping someone here has seen/heard of this problem before.
Problem:
Clean system without SW installed before. Install folders and Solidworks
keys removed from registry before each new attempt to fix problem.
Install goes fine, with no errors. Launch SW for first time and get the
license agreement window as expected. Click agree and get dynamic help
window. Clear that and I'm left with the SW desktop. In 2007, if I
click "new", I get the standard format and units selection box. Click
OK, and then nothing?back to the SW desktop. Repeat, and get same
results. In 2006, that question was asked during install, so I get to
the template selection window and can create a new file. New file opens,
and there are no toolbars. None. Not even the defaults. Does this
indicate installation error writing some registry info?
In both cases I close SW and restart. SW splash screen leads to SW
desktop and then the license agreement screen comes up. Click agree and
dynamic help is there again. Clearly SW is not writing to the registry
properly. Why? I've tried all the usual suspects.
Things checked/tried/tested:
No Anti-virus/firewall/anti-spyware running during install (with network
connection disabled as well). No change
Verified write permission to registry. No change
Verified administrator rights. Account always had admin level
permissions.
I'm out of ideas. No errors were given during installation and many
things are being written to the registry (I know because I've deleted
them several times). It seems to be something that happens after install
that keeps it from updating the necessary entries to save its "state"
after being run. No settings are being saved.
I've installed many versions on many PCs and NEVER seen anything like
this happen. All online searching indicates people who have registry
problems get an error saying so. I'm not sure where to go from here
short of reinstalling windows (which would be a MAJOR hassle on this
machine).
This PC did have SW2007 Beta installed at one point but I never had time
to work with it. I can't remember if this issue occurred on the beta. I
don't believe so. It was removed long ago.
Not that it matters, but this is my home PC that I'm trying to use to
test 2007 before I roll it out to everyone at work. Of course I don't
have time to do this testing at work...
Any ideas?
MHill
Reply to
MHill
Loading thread data ...
I found I had this problem, if a previous install, was removed. Not all of the registry entries were being deleted.
I found this FREE program from
formatting link
windowscare V2 personnel.
You will be amazed at the amount of reg.system etc.., errors even on a clean Windows and Solidworks install.
And NO, I do not work for or have any connection with iobit, I just found this program by chance. and as it is for your home PC, it's free.
Don't use the free defrag program there, in my experience, it was not very good when using SW.
Reply to
pete the first

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.