not remembering toolbar

I have SW2007 sp5.0 installed and it is not remembering the default toolbars or the changes to the toolbars that I do.
any suggestions on how to lock the toolbars or fix this
TIA Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The only fix, (without reinstalling or clean install) that I have applied to fix this problem in the past was to rename the SW registry key (HKEY_CURRENT_USER\Software\Solidworks ) so it can be reset/ rebuilt.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi Brian,
as Paul already stated -> rebuild the SW registry key seems to be the only solution to heal this problem (till the next mess up). Anyway the toolbar setting will be messed up from time to time so it is a good advice to save and export the SW regkey as backup. Then you can easily restore the personal toolbar settings when the problem occurs next time.
HTH
Jojo
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How bad is the problem. Sometimes the solution is to just have a drawing, model and assembly all open at the same time, then switch back and fore between them to see what jumps around. Sometimes issues are caused because different document types are using the same toolbar, but you have them in different locations for each, which causes them and other toolbars to shift around as you swtich between document types.
Matt Lorono http://sw.fcsuper.com http://www.fcsuper.com/swblog
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank for the tip, I tried this first and I still had the problem. I then tried the first suggestion and had to rest all my options and settings. Then I opened each doc type as you suggested and set the toolbars and that seemed to work fine.
Thanks again Brian
wrote:

How bad is the problem. Sometimes the solution is to just have a drawing, model and assembly all open at the same time, then switch back and fore between them to see what jumps around. Sometimes issues are caused because different document types are using the same toolbar, but you have them in different locations for each, which causes them and other toolbars to shift around as you swtich between document types.
Matt Lorono http://sw.fcsuper.com http://www.fcsuper.com/swblog
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.