Photoworks BSOD

Using SW 2005 SP4.0.
I've tried this on two different systems now, the only common element
being the NVIDIA Forceware 81.95 drivers; but Photoworks repeatedly
locks-up and causes a blue screen in nv4_disp while working on a simple
glass model.
I've applied a simple spherical checker environment & glass material,
then I let the preview window render or switch back to OpenGL preview
when I'm done, do a few other things then close the material/scene
dialog and return to the part, but while closing out it grinds to a
halt, then locks-up and goes to blue screen with the above error.
What are your experiences with Photoworks and BSOD's? Is this limited
to the one service pack or is it a problem with the preview? I have
never seen this happen on a workstation with SP3.3 and roughly the same
configuration while working on the same part/scene.
I'm trying new drivers right now, but maybe I'll have to revert or
upgrade the SP, I just don't know at this point.
Reply to
deimos
Loading thread data ...
What is the BSOD? Please provide the first couple lines, i.e., STOP 0x000003E ( blah blah...
Reply to
TOP
...
The device driver got stuck in an infinite loop....
STOP: 0x000000EA (0x83F2A3C8,0x842D2B90,0xF79OECB4,0x00000001)
nv4_disp
...
I tried the newest drivers available, 81.98, but to no avail. However I have a much better sense of exactly what steps are causing it to crash and I can now reproduce the BSOD.
It seems to happen when utilizing the preview window for selecting a face or otherwise, then clicking outside of it in the component tree or elsewhere. This basically causes it to freeze momentarily, and if it doesn't come back right away, it can pause a few more times before blue screening. This is working from a fresh SW2005 SP4 install.
It seems isolated to a problem between Photoworks and the display driver or the Photoworks OpenGL implementation. Both systems have very different motherboards/cpu/ram configurations, but a Geforce FX in one and a GF6 6600GT in the other. The newer drivers made no difference and I can't find a known bug in the driver release notes going back through 7x.xx.
Reply to
deimos
Did you set your PW options/document poperties to limit memory?
..
Reply to
Paul Salvador
Yes, 400MB in this case. Total physical RAM installed is 1024MB.
Reply to
deimos
SYMPTOMS You may receive one of the following Stop error messages: STOP 0x000000EA THREAD_STUCK_IN_DEVICE_DRIVER STOP: 0x100000EA THREAD_STUCK_IN_DEVICE_DRIVER_M CAUSE This issue may occur if the display driver is caught in an infinite loop while it waits for the video hardware to become idle. This issue typically indicates a problem with the video hardware or that the display driver cannot program the hardware correctly. RESOLUTION To resolve this issue, obtain and install the most current driver for your video adapter, or replace your video card. =============================================================
You may want to make SW aware of this. My guess is that they don't always check PhotoWorks when they make up their Graphics Card list.
Another thing you may want to do is a clean install of the video card drivers. You do this by uninstalling the GeForce driver in Safe Mode, rebooting and then reinstalling. You can make sure you have removed all unnecessary drivers by using the procedure here:
formatting link
Reply to
TOP
I did a little research as well and found the same, and that this infinite loop was more commonly associated with some cards not even working at all (i.e. not booting Windows or err'ing out).
Here's an update though. I can now get it to crash in less than 10 seconds.
1. Load assy. 2. Select component to edit texture. 3. Photoworks > Material 4. Drag out the preview window larger. 5. Click anywhere else... 6. BSOD
Since updating to SP5 off a fresh SW2005 install, it now crashes much faster!
I'm going to try reverting to a SW approved driver set (71.84 WHQL) on one workstation and see what happens.
Reply to
deimos
I think I've got it fixed now.
I rolled back to 71.84 and so far with SP5, I haven't had any BSOD's or crashes. Same as our SP3 workstations using Quadros and 71.84.
Upon further looking into the driver, it appears that "OpenGL 2.0" support was the only major change to OpenGL in recent versions. Around the lates 7x.xx versions, beta OGL2 support was added through a debug feature, but in the newest drivers, OpenGL 2 support is fully active. As these drivers are for the consumer cards, they're primarily geared towards gaming and not professional apps. I wouldn't be surprised if they're interpreting OpenGL calls differently or something just plain broke in the 80.xx series.
It's getting way too late and I'm sick of messing with Photoworks... (stupid planar mapping!). Goodnight all. Don't let the bed bugs bite.
Reply to
deimos
LOL, and people say SW performance suffers with newer releases/sps. Proof to the contrary.
Reply to
Brian

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.