Repeat: Does IMPORT not work when editing standards data?

Didn't have any luck the last time I posted this question, and it may be
that nobody knows an answer, but I thought I would try one last time.
I've tried in the eng-tips.com Solidworks forum also with no luck, so
there's apparently no obvious answer. Anyway, I'm working "direct" now
for a company and am transitioning them to SolidWorks from AutoCAD, and
I'm working in SolidWorks 2005. Perhaps2006 or the Beta of 2007 has the
following problem fixed, but I can't test that. I would certainly think
that it would be worth fixing if it's broken.
The Truarc retaining rings in the Toolbox are a bit of a problem to ME
specifically because my new employer (like many companies) don't buy
from Truarc. They buy from Rotor Clip which has basically identical
parts -- at least geometrically -- with analogous part numbers. That's
NOT the problem. The problem is to do with creating and then editing a
new set of standards data.
What I wanted to do was to "Create New Standard" (using the Truarc
library as the "Designed From" source) for Rotor Clip retaining rings.
Then of course I wanted to edit the standards data for that new standard
library so I could put in proper part numbers for Rotor Clip. There are
"Export" and "Import" functions available from the "All Configurations"
tab for each of the various kinds of External and Internal rings.
That's a really nice thing, ostensibly enabling one to export to a
spreadsheet, modify the data wholesale there and then reimport into the
standards data. The only problem is that the "Import" function doesn't
work!! It appears to work -- or at least be doing something -- when you
'point to' the spreadsheet that has been modified, but after finishing
the Import function (without any error messages) nothing has actually
changed. The data is just the same, and I can confirm that also by
trying to insert parts from that Toolbox library. I note that if I
don't make the modifications according to understandable rules I DO get
an error message, so obviously there IS code evaluating the spreadsheet
as it is trying to import the data.
For those who want to use this great functionality, that's really
frustrating. I have checked to make sure that the problem exists on
more than one installation, and have also checked to make sure that I'm
not trying to modify a file with a Read Only (or Hidden or System)
attribute bit set. No such luck. Does anyone know of a "fix" or am I
SOL? Does anyone even know whether this functionality works in 2006?
TIA
Mark 'Sporky' Stapleton
Owner, Watermark Design, LLC (my one-man company)
formatting link

and
Engineer, Profero Systems, Inc
formatting link

Reply to
Sporkman
Loading thread data ...
Perhaps you should report it as a bug to your VAR and they can ask a SW person with responsibility for that part of the code about it.
Reply to
neil
Have already reported, not only to my VAR, but to a contact that I have in SolidWorks technical support. No answers.
Thanks anyway, but what I want to know is whether anyone can duplicate the problem in 2006 and whether or not anyone has experience with this functionality that might indicate the I'm "not holding my mouth just right".
'Sporky'
neil wrote:
Reply to
Sporkman
maybe you should provide a file for people to try?...
Reply to
neil
Good idea. I'll upload one tomorrow from work. Thanks for the input.
Mark
neil wrote:
Reply to
Sporkman
Interesting
I did not know this sort of functionality existed, could be fun to play with....Thank you for pointing this out to me and everyone else.
FWIW I could replicate the problems you have encountered, no big surprise here. I could however (and this is one crappy workaround) is change the values in the 'sizes' tab, I could not however cut and paste more than one cell at a time into this table from an xls file so it would be a data entry issue and probably not what you were looking for. I will do some digging and see what I can come up with.
I am pretty sure are on the 2007 beta, so have you tried to replicate this in 2007, again I am sure this is not an answer to the problem as most do not adopt the new version until SP 2 or 3.
Ben
Sporkman wrote:
Reply to
Ben Eadie
I have substantial further info, Ben, including how to use this functionality. I have been able to successfully Import a modified (exported) spreadsheet to create new data. Read my new TIP dated today. It will be appearing in a few minutes time.
Mark
Ben Eadie wrote:
Reply to
Sporkman

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.