No smoke from Lionel PRR K4 (#6-38025)

We just bought a PRR K4, from Lionel's 2002 catalog in brand new condition (the box had never been opened before). When
we first ran it and turned on the smoke generator, a little came out, which we thought was remarkable considering it had been sitting in a box for four years. After about 15 minutes smoke production started to decrease, so per the manual we added 8 drops of the included smoke fluid. That's when the problem started.
After adding the fluid the smoke generator started to spit, so we figured we added too much. We turned the locomotive over and a tiny amount of fluid came out. And now the unit doesn't produce any smoke at all. We've let the engine sit overnight and tried running it for a few hours with the generator on, but that hasn't helped so far.
If we did add too much fluid, how long will it take to get rid of it? We can smell heated fluid from the smoke stack, so we think the heater element is ok. Should we just leave it for a few days, or continue to run it with the smoke unit on?
Thanks in advance for any help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Dec 21, 5:39 pm, "blahblah snipped-for-privacy@sbcglobal.net"

------------------------------------------------------------------------------------------------------
I hope your problem has been solved. Here are some sites that might be of value to you:
Lionel Tips and FAQs:
http://www.lionel.com/ForTheHobbyist/FindexTips.cfm?promo 1202
Chris Coleman's FAQ:
http://www.spikesys.com/Modelrr/faq1.html
TCA Toy Trains Mailing List:
http://groups.yahoo.com/group/toytrains /
Yahoo! Lionel Groups:
http://dir.groups.yahoo.com/dir/Hobbies___Crafts/Models/Trains_and_Railroads/Lionel
Bill Bill's Railroad Empire N Scale Model Railroad: http://www.billsrailroad.net Brief History of N Scale: http://www.billsrailroad.net/history/n-scale Model Railroad Books, Toys, and Trains: http://www.billsrailroad.net/bookstore Resources--Links to 1,200 sites: http://www.billsrailroad.net/bills-favorite-links
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.