Lincoln Ranger won't weld.

I have a Lincoln 8551 weld-power unit that welded fine last December. Started it to use two weeks ago and it won't strike an arc. Polished the armature and the
brushes are in great shape, that about exceeds my troubleshooting skills. Any thoughts? I've been told that these units can lose excitation.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Is this the unit you're talking about? http://www.lincolnelectric.com/assets/servicenavigator-public/lincoln3/im308.pdf A little more info would help. For example, will it still generate AC power? If yes, the excitation is likely ok.
hth,
bob prohaska
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Had a ranger 250 that would generate AC fine, but stopped making an arc.
Fortunately in warranty. Darn thing took a main circuit board replacement to fix, from what I recall- the guy working on it went through most other replaceable bits while I watched, but didn't have one of those on hand, so I left it and it was shipped back to my local store when fixed.
--
Cats, coffee, chocolate...vices to live by
Please don't feed the trolls. Killfile and ignore them so they will go away.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote in message

https://learn.sparkfun.com/tutorials/how-to-use-a-multimeter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.