Trouble with Revell..

I recently bought a 1/48 scale model of the PBY-5 and when I opened the box, the clear parts were missing from the kit. I tried to go online to order the
parts and the stupid form will not let me enter it. I e-mailed them and told them about it and they gave me the same thing. Go online and order it. I will attempt to call them tomorrow and tell them what I think about their kits. I have not ever had this happen to me....
Has anyone ever had problems with them?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

didn't you post this exact same thing a short while ago?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, because my computer went haywire and could not bring up the page. There were old posts that kept coming up and it never did refresh.
But sorry though. I though some folks migh could redo it...
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

that's ok, i was thinking you might have trouble. did you get any help at all?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
on 1/21/2009 10:14 PM (ET) snipped-for-privacy@some.domain wrote the following:

Yep. He did on Jan 6th. I guess he just posts, and not reads.
--

Bill
In Hamptonburgh, NY
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

or has a problem...like no luck with revell.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.