Broken out section lost it's sketch?

I had a drawing with a few broken out sections (BOS) all was well. Today I opened it up and hit CTRL-Q all of the sudden 4 prompts saying Operation
Failed Due to Geometric Condition. After scratching my head for a bit I noticed it had to do with one of the BOS. It seems one of the BOS lost it's sketch. Has any one ever had this happen? I was able to fix it by editing the non-existent sketch and adding a new spline for it to use and rebuilding with the spline selected. Now all is well but I am afraid. Was this a fluke incedence or is it an underlying problem I will be dealing with for a while. Comments?
Corey Scheich
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I use it a lot but never seen just disappear.....the reason is almost always that I have moved in some way...maybe editing the size of the part
Krister L

I
it's
editing
rebuilding
a
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Nope the part hasn't changed one bit since the Drawing was created a month or 2 ago.
Corey

Today
for
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I almost guessed.....I was refering to myself and when I had problems like this.
Krister L

Operation
I
lost
a
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.