Mazak RS232

I keep getting "parity h" alarms when I try to upload from Bob Cad to
Mazatrol. However, I can download fine from Mazatrol to PC. I have
both setup for 7,2,9600,XON/XOFF,no parity. Any Mazak gurus out
there???
Reply to
george.schweikert
Loading thread data ...
how old is the mazak, i know ours are T32 controls and they were only 4800 baud and i believe even parity (but can't remember) i think the settings were 8,1,4800,even
also make sure you are plugged into the correct port, some of out mazaks had 3 ports.
Reply to
Stan-O
Here is the settings for the T32 i was talking about, i was off on a few, must be getting mixed up with my haas
hope this helps
-S
[COMPORTSETTINGS] COMPORT = COM2 BAUDRATE = 9600 PARITY = EVEN STOPBITS = 2 DATABITS = 7 FLOWCONTROL = SOFTWARE HWFLOWTYPE = RTSCTS XONCHAR = 17 XOFFCHAR = 19 PARITYINSERT = 35 USEPARITY = No DTR_ENABLED = Yes RTS_ENABLED = Yes IGNOREERRORS = No PORTMODE = 0 EMULATESAFEXOFF = No EMULATEWAITXON = Yes IGNOREDRIVERERR = No SINCLECHARIO = No
Reply to
Stan-O
This is a common mistake on the T32 control. At the CNC control, set it 8,2,9600,XON/XOFF, no parity. (8,N,2,9600)
At the PC, set it to 7(seven), 2, 9600,XON/XOFF, EVEN parity.(7,E,2,9600).
Yup, the settings at the CNC and the PC are slightly different.
Good Luck. samurai.
Reply to
samurai
YES, YES, YES THIS WORKED SAMURAI !!! THANK YOU :)
Reply to
george.schweikert

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.