dimension input 'calculator'

Hello,
I'm having trouble getting the dimension value input box to do math.
It seems to do divion fine, but anything else give the error "please
enter a number between 0.00000394 and 393700.78750157"
Has anyone else noticed this? Is this a bug?
SolidWorks 2005, SP0 : upgrade from SW2004 SP03.
Mabie I should reinstall SW from scratch?
Any help is appreciated.
Thanks, Anders
Reply to
A Rasmussen
Loading thread data ...
I've never seen this. I have always considered the math functions within dimension input boxes quit powerful and reliable. Unless of course you are using multiple units which you have to make sure you type in the actual units (1in + 1mm). Could you please give an example of exactly what you are typing in to get it to fail (every character and space).
Reply to
Seth Renigar
Usually, this sort of things is blamed on anti-virus software preventing a proper install. A reinstall with AV disabled might be in order. I've not had to do this yet myself. If I'm wrong, someone please correct me.
Reply to
Dale Dunn
I don't believe it is ever advisable to upgrade your installation if you want to keep a copy of the last version around until your drawings have all been updated you can do a new install to another folder. Otherwise Uninstall the older version and then do a clean install. ALWAYS BE SURE TO TURN OFF VIRUS PROTECTION WHENEVER YOU ARE DOING AN INSTALL OR UPDATE. I have heard a few times that one of the AV programs sometimes looks like it is off in your task bar but you have to open it up completely to actually stop it enough to do an install.
Another possible reason that your equation may fail is because it is evaluating to a negative number which isn't allowed in SW try this
abs(your entire equation)
it will evaluate the absolute value of your equation so if you are negative it will correct it to a pos.
Corey
Reply to
Corey Scheich
To do a clean uninstall and reinstall see
formatting link
Regards, Scott
Reply to
Scott
Post an example of what you are trying to get the dimension box to calculate.
Reply to
Jeff Parker
Hello again,
I installed sw2005 as a test on another computer and it worked just fine. So I uninstalled all of the solidworks 2004 stuff and resintalled 2005 from scratch and that seems to have worked.
It also seems to run faster now...
Thanks for the response, Anders
Reply to
A Rasmussen

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.