Installation Problem

I was getting the following error when trying to upgrade from 2006 sp4 to 2006 sp4.1 so I uninstalled sw2006 and now I get the same error trying to reinstall sw2006. Any suggestions?

Error 1402, Could not open key: UNKNOWN\swBackOfficeCore.Class1\CLSID, Verfy that you have sufficient access to that key, or contact your support personnel.

I do still have a working copy of sw2005 sp5 on this machine. Would that cuase any problems?

Anti-virus if off. I have administrator rights. OS is Windows XP SP2.


Reply to
Loading thread data ...

Well when I see key I think registry key. Maybe for some reason it can't modify that registry value? Other than that my thought is you have a bad download of 06. Try redownloading and making sure the checksum passes.

Reply to
Mr. Who

Got it working. Here is what I had to do.

  1. Go in the registry editor. The top most folder listed in HKEY_Classes_Root. Right-click on this folder and select PERMISSIONS from the menu.

  1. Once there, look through the permissions listed and make sure that Administrators and System are both listed. If they are not, please refer to the bottom of this write-up under "Conditional Step".

  2. If they are both listed, make sure that both have Full Control checked on ALLOW. If they are not yet checked, click in that box an select APPLY. This will put the proper permissions through the registry an should set you up for a good installation. Once finished with this area select OK and close the Registry Editor.

  1. Once done, retry the installation of Diskeeper.

Conditional Step

--------------------- If you've found that System and/or Administrators are not listed in the permissions section, you will need to add them. To do so, click the Add Button and in the following screen type System or Administrator depending on which is missing. (You may only do one at a time). Once typed select the CHECK NAME button which will end up highlighting the name and then you can select OK.

Reply to

Same thing happened to me when I tried to update from 2006 SP3 to 4.1. The fix was just as was described. Something happened to change those permissions somehow. Something in the install?

Reply to

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.