Problem bei Vertauschen der Inverter eines 4069

Hallo NG!
Ich habe mir eine Schaltung gebastelt, welche alle sechs Inverter eines CMOS 4069 benutzt und im Steckbrett wunderbar funktioniert. Für
das fertige Layout möchte ich nun u.a. die Inverter an den Pins 1-2 und 11-10 gegeneinander tauschen, um kürzere Verbindungen hinzubekommen. Wenn ich entsprechend umstecke funktioniert meine Schaltung seltsamerweise nicht mehr.
Prinzipiell müssten die 6 Inverter doch komplett eigenständig und gleich sein und somit in beliebiger Reihenfolge verwendet werden können, dachte ich. Wer kenn mir einen Rat geben?
Vielen Dank schon mal im Voraus! -Ingo
P.S.: Falls die Schaltung selbst von Interesse ist:
http://img82.imageshack.us/img82/7435/mof1lh2.jpg(3-4,5-6 und 9-8 sollen auch noch entsprechend der roten Nummern vertauscht werden, daran wage ich mich aber noch nicht...)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ingo Kaiser wrote:

Sollte eigentlich funktionieren. Steckbretter sind allerdings nicht die zuverlaessigsten Geschichten. Miss mal nach, ob die Verbindungen wirklich da sind. Noch eine Randbemerkung: UB Versionen knallen bei winzigstem ESD durch. Einmal schief auf den Stuhl gesetzt und angefasst ... PICH.
[...]
--
Gruesse, Joerg

http://www.analogconsultants.com /
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hallo Joerg!

Daran hab ich schon gezweifelt... Danke für's Bestätigen!

Ich weiß, deswegen hab ich die Schaltung inzwischen 3x in verschiedenen Kombinationen hier zusammengelötet rumliegen. Immer der selbe Effekt.

Danke für den Hinweis! Hab schon testweise eine der Schaltung, die funktionierte, nochmal hin- und zurückumgebaut, jedes Mal mit dem erwarteten Effekt. Den IC hab ich auch getestet, sollte in Ordnung sein. Irgendwie stehe ich hier total auf dem Schlauch.
Grüße, -Ingo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hallo, Ingo Kaiser wrote:

auch wenn die einzelnen Inverter eigenständig sind, hängen sie an der gleichen Stromversorgung und sitzen in einem Gehäuse. Daher könnte hier dir die Kapazitive Kopplung der einzelnen Inverter evt einen Strich durch die Rechnung machen. Was ist, wenn du die Inverter auf mehrere ICs verteilst, machen die Wunsch Pinbelegungen dann immer noch Stress? Hängt direkt an den Stromversorgungspins ein 100nF C? Wirkt irgendein Verbindungsdraht evt als Antenne?
Gruß Jan Conrads
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Also sind sie doch in Ausnahmefällen unterschiedlich... Das wäre zumindest eine mögliche Erklärung. Werde morgen/Montag ausprobieren, was passiert, wenn ich das auf genügend ICs verteile.

Ja, auch. Andere testweise auch.

Gute Frage...
Vielen Dank und Grüße, -Ingo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hallo Ingo,

was soll denn das Teil machen? IMHO ist die Schaltung unsauber, allein schon wegen C2, der sich weder über die Diode noch über den Enigang entladen kann. Ausserdem besitzt der 4069 keine Schmitttriggereingänge. Du betreibst das Teil also in einem nicht definierten Bereich. Da der Übergangsbereich nicht unbedingt durch eine sehr hohe Verstärkung ausgezeichnet sein muss, wird diese Schaltung sehr vom jeweiligen Gatter-Exemplar abhängen. Normalerweise sollte man innerhalb eines IC nicht allzugroße Unterschiede erwarten, aber was nicht spezifiziert ist, muss bekanntlich auch nicht funktionieren. Mach mal den 40106 rein AFAIR hat der Schmitttrigger und könnte daher reproduzierbarer Deine Lichtblitze auswerten. C2 bleibt davon aber unberührt. Die LED ohne Vorwiderstand zu betreiben geht zwar mit den CD4xxx in der Regel schon, schön ist aber etwas anderes.
Marte
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Vielen Dank erstmal für die ausführliche Antwort!

Im Endeffekt soll es, wenn im Dunklen ("nachts") ein Lichtblitz kommt, über einen kurzen Zeitraum blinken. Wenn es dauerbeleuchtet ("tagsüber") wird, soll es nicht blinken. Das ganze allerdings in möglichst stromsparender und kompakter Konfiguration.

Mit Sicherheit! Ich habe nämlich relativ wenig Ahnung davon und auch...

...noch nicht verstanden, _wie_ sich C2 entlädt. Der Punkt ist aber: Er tut es. Zumindest, wenn er an der Diode zu Ausgang 10 und Eingang 9 hängt (In der "Originalschaltung", also ohne die roten Änderungsziffern). Dann funktioniert das Ganze nämlich wie es soll und blinkt nach einem Lichtblitz für einige Sekunden. Nur lässt sich die Schaltung dann nicht vernünftig auf kleinem Bauraum anfertigen. Aber, wie vorher beschrieben, wenn C2 beim getauschten Inverter zwischen der Diode zu 2 und Eingang 9 hängt, dann klappt es eben nicht mehr.

Das ist wahrscheinlich der Grund, warum es in der einen Konfiguration klappt und in der anderen nicht.

Das verstehe ich nicht. Nicht definierter Bereich?

Hmm. Das Erkennen der Blitze funktioniert ja bisher immer, ich denke, den 40106, der übrigens Schmitttrigger hat, ändert hier nichts. Das wirkliche Problem ist ja, wie Du richtig erkannt hast, das Entladen von C2 (ich mir aber bisher nur logisch und nicht anhand der Schaltung herleiten konnte, daher vielen Dank für die Bestätigung!).
Gibt es eine Möglichkeit, die Schaltung einfach so zu modifizieren, daß C2 dann entladen wird, wenn er entladen werden soll? Oder bringe ich evtl. nur noch mehr durcheinander, wenn ich parallel zu C2 einen großen Widerstand schalte?
Vielen Dank nochmal für die ausführliche Antwort, -Ingo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hallo Marte,
vielen Dank erstmal für die ausführliche Antwort. Hat mir in Sachen Verständnis sehr gut weitergeholfen, aber leider hab ich das Problem noch nicht gelöst.

Im Endeffekt soll es, wenn im Dunklen ("nachts") ein Lichtblitz kommt, über einen kurzen Zeitraum blinken. Wenn es dauerbeleuchtet ("tagsüber") wird, soll es nicht blinken. Das ganze allerdings in möglichst stromsparender und kompakter Konfiguration.

Ja und nein: Zum einen habe ich relativ wenig Ahnung von dem ganzen... Zum anderen ist der Eingang aber zwar hochohmig, hat dann aber doch nur mit 12MOhm. Darüber entlädt der sehr kleine Kondensator dann, wenn ich die Schaltung richtig verstanden habe, doch recht flott. (Ich nehme mal an, daß die Durchflußrichtung passt, da sie ja gleich der Diode außen sein müsste.) Der Punkt ist aber: Es funktioniert. Zumindest, wenn C2 an der Diode zu Ausgang 10 und Eingang 9 hängt (In der "Originalschaltung", also ohne die roten Änderungsziffern). Dann funktioniert das Ganze nämlich wie es soll und blinkt nach einem Lichtblitz für einige Sekunden. Nur lässt sich die Schaltung dann nicht vernünftig auf kleinem Bauraum anfertigen. Aber, wie vorher beschrieben, wenn C2 beim getauschten Inverter zwischen der Diode zu 2 und Eingang 9 hängt, dann klappt es eben nicht mehr.

Das ist wahrscheinlich der Grund, warum es in der einen Konfiguration klappt und in der anderen nicht.

Das verstehe ich nicht. Nicht definierter Bereich?

Hmm. Das Erkennen der Blitze funktioniert ja bisher immer, ich denke, der 40106 (der Schmitttrigger hat) ändert hier nichts. Das wirkliche Problem ist ja, wie Du richtig erkannt (und mir somit dankenswerterweise bestätigt) hast, das Entladen von C2.
Gibt es eine Möglichkeit, die Schaltung einfach so zu modifizieren, daß C2 dann entladen wird, wenn er entladen werden soll? Oder bringe ich evtl. nur noch mehr durcheinander, wenn ich parallel zu C2 einen großen Widerstand schalte?
Vielen Dank nochmal für die ausführliche Antwort, -Ingo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hallo Ingo,

Lichtblitze bei Tag interessieren Dich also nicht?

Woher hast Du denn diese Weisheit? In der Regel wird der viel hochohmiger sein.

Reine Glücksache.

Wohl dann aber hoffentlich mit SMD, doppelseitig bestückt und so ;-)

So wird es sein.

DEr Eingang ist unterhalb 30% der Versorgungsspannung als LOW zu sehen und oberhalb 70% als High. alles dazwischen darf das IC schalten und walten wie es will, da ist nichts festgelegt, was es wie tut.

Was ist bei Dir immer? In 10 Jahren bei einer Auflage von 100.000 Gerätten? oder doch eher bei der beschriebenen einzigartigen Anordnung in einem sehr begrenzten Beobachtungsraum? Wie ist "Lichtblitz" definiert?

Das ist ja die einfachste Übung. Wenn es aber ein bischen darauf ankommt, dass die Nachblinkzeit nicht ganz beliebig ist, würd ich auch hier einen 40106 empfehlen, der kostet auch nicht mehr, ist aber für so langsameEingangsspannungsänderungen besser und nicht zuletzt stromsparender, weil die Stromaugnahme der 4XXX im Analogbetrieb auch ganz schön hegftig werden kann. Deine Schaltung setzt zwei Deiner Eingänge aber recht häufig in den undefinierten Bereich.

Nee, das ist dann auch schon die Lösung: Mach 10 MOhm parallel dazu und gut ists. Ggfs mach auch ein kleiner Schutzwiderstand von ca 1 kOhm zwischen C2 und dem Eingang, damit beim Kurzschluß der Versorgungsspannung die Eingangsschutzdioden des Eingangs nicht sterben.
Viel Erfolg
Marte
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Genau. Die Schaltung muss nur auf kurzzeitiges Durchschalten vom LDR reagieren.

Aus meinem DMM. Habe bei zwei fabrikneuen ICs jeweils die Ein-/Ausgänge gegenüber den beiden Versorgungsspannungsanschlüssen gemessen. Die Eingänge alle 12.4MOhm, die Ausgänge 14.5.

Befürchte ich auch fast. Interessanterweise klappt es bei (allen) vier ICs, die ich hier habe, gleich... Es scheint also so zu sein, daß die einzelnen Inverter in einem IC fertigungsseitig doch unterschiedlich sind, die ICs aber alle gleich.

Ich füge noch hinzu: Von mir anfertigen lässt. Hab gestern noch, weil ich keine passenden "großen" Kondensatoren mehr hier hatte, SMD-auf-2.54mm-Streifenrasterplatine gelötet. Das war dann wirklich reine Glückssache...

Nur hobbymäßige vielleicht zehn Stück. Das Teil soll als Station bei einer Nachtwanderung dienen. Wenn ich 100000 produzieren (und damit schätzungsweise dann auch was verdienen) wollte, fände ich es zu dreist, jemanden zu bitten, mir gratis zu helfen.

Als "Leuchte mit einer Lampe drauf, bis es reagiert". Im Endeffekt also ein Übergang im Zehntelsekundenbereich am LDR von viel Ohm nach wenig Ohm.

Hab schon welche bestellt. Vielen Dank auch direkt für den Hinweis mit der geringeren Stromaufnahme!

Danke! Und vielen Dank auch nochmal an dich für die geduldige Beantwortung meiner Fragen!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hallo INgo,

Du hast alles nur keine Ein bzw Ausgangswiderstände gemessen. Im Zweifel waren das Diodenstrecken.

höchstens in dieser Fertigungscharge.

Viel Spaß bei den Nachtwanderungen. Fin ich toll, dass jemand so was organisiert. Jugendarbeit? Ist bei mir schon lange her, hat aber viel Spaß gemacht.
Marte
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Du meinst, ich hab das rote und schwarze Kabel meines DMMs flaschrum drangehalte? Ja, stimmt leider.
Werde jetzt erstmal auf die neuen Teile warten und dann die Schaltung neu und mit mindestens einem Widerstand mehr aufbauen.
Vielen Dank nochmal für die viele Hilfe! Grüße, -Ingo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Marte Schwarz schrieb: Die LED ohne Vorwiderstand zu betreiben geht zwar mit den CD4xxx

Genau da sehe ich das Problem. Die LED lässt sich zwar zum Leuchten bringen, aber möglicherweise reicht die Spannung am belasteten Inverterausgang Pin 4 nicht mehr, um den nachfolgenden Eingang Pin 11 ordentlich zwischen High- und Low-Pegel umzuschalten (vor allem, wenn dann noch eine Si-Diode in Reihe liegt). Durch Toleranzen kann es sein, dass der eine Inverter gerade noch funktioniert, ein anderer im gleichen Gehäuse aber gerade nicht mehr.
Gruß, Alexander
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ingo Kaiser schrieb: Mach doch mal parallel zu C2 einen Widerstand ~ 470k, geht's dann? Gruß Dieter
--
Ein u aus Mailadresse entfernen
;-)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Ja, extrem kurz. 10MOhm bringen es auf ca. eine Sekunde.
Was mich aber noch wundert ist, daß es in der einen Konfiguration ohne parallelen Widerstand klappt, in der anderen aber nicht...
Danke und Gruß, -Ingo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Nun, der Eingangswiderstand von CMOS-Gattern gehrt wohl zu den typischen Daten, die nicht garantiert werden, da er bei typischen Anwendungen irrelevant ist. Ich wrde einfach den Kondensator so vergrssern, das Du mit einem 100kOhm Widerstand parallel Deine gewnschte Zeit erhlst. Das ist dann wegen des fehlenden Schmitt-Trigger-Eingang immer noch nicht korrekt, wird aber vermutlich funktionieren. Gruss Harald
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hallo Harald,

Na mach mal langsam, 1 MOhm ist durchaus ausreichend niederohmig, ich würde sogar 10 MOhm einbauen. Sonst gibt es nur unötig Stress mit der Ladezeit für einen unnötig zu groß dimensionierten Kondensator.

Im Zweifel flackert es eben beim ausschalten. Ich gehe davon aus, dass ihn das am wenigsten stört.
Marte
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.