Transformer Question -- Newbie

Hello All and Happy Holidays...
I had purchased a Lionel Polar Express set for my son for Xmas and have run into somewhat of a problem with the transformer (I think). This is our first
venture into motorized trains (he's been a wooden railway fanatic for years), so I'm not sure if what I'm experiencing is normal for this type of set or not.
I set up the train last night. It seemed that it took a few minutes for the transformer to "warm up". The green light was on but when I moved the throttle lever, nothing would happen. Then after a few minutes, the train finally started moving. I got it to go forward, neutral, reverse, etc. No problems. I unplugged it and turned in for the night.
This morning my son obviously wants to take it for a spin. We plug it in and the green light comes on and the same thing happens -- the train won't go. So we wait a few minutes and nothing. Then the green light went out all together. I unplugged everything, checked all the connections and after an hour tried it again. Nothing. The transformer hums (slightly) but still no green light, nor moving train.
Does anyone have any idea what might be causing this? Am I doing something wrong?
Thanks in advance...
George
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

and have run

is our first

fanatic for

this type of

minutes for the

moved the

the train

reverse, etc. No

plug it in and

train won't go.

out all

and after an

but still no

doing something

George,
If you purchased your set at a train store that carries Lionel transformers, they will generally swap yours out for a replacement.
If not, contact Lionel Customer Service at (586) 949-4100, extension 1350 and tell them what's happened. They'll give you a Return Authorization number to send your transformer in for a replacement.
Personally, I wish they would do an OEM agreement with MRC and start including the MRC 600 in their sets. I think it would save a great deal of aggrevation for a lot of folks. -- Len Head Rust Scraper KL&B Eastern Lines RR Museum
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check with your dealer. I believe Lionel came out with a replacement terminal track (the piece that connects to the transformer) which corrects this sort of trouble.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Len wrote on 12/25/04 1:07 PM:

Thanks for the info Len. I called this morning and they're sending me a new one.
Best regards,
George
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Polytechforum.com is a website by engineers for engineers. It is not affiliated with any of manufacturers or vendors discussed here. All logos and trade names are the property of their respective owners.