Electronics workbench(spielerei oder nicht?)

Hallo Elektronikfreunde
Wie ernst kann man Sim. Programme wie zb. Electronics workbench nehmen.
Ich habe eigentlich keine Erfahrung damit, meine Schaltungen habe ich immer
konventionel aufgebaut, bis vor kurzem.
Mit Electronics workbench 5 baute ich auf die Schnelle einen standart
Multivibrator(Wechselblinker), einfach auf dem Bildschirm. Frequenz ca. 1
bis 2 Hz. (auch unsymmetrisch)
Die Schaltung kippt regelmäßig, denoch nac ca 20 Sec. beginnt die ganze
Geschichte unregelmäßig zu blinken, dann schwingt sogar das Ganze.
Die Schwingung kann man auf dem virtuelem Oszi beobachten. Die Amplitude
der Schwingung wird immer kleiner, bis es aufhört, dann funktioniert die
Schaltung wieder für die nächsten 20 Sec.
Ich habe mit verschiedenenKapazitäten und Transistoren rumexperimentiert.
Gleiches Ergebnis.
Die selbe Schaltung konvenzionell aufgebaut funktioniert aber.
Hat Jemand Erfarung damit?
Grüße
Axel Rose
Reply to
Axel Rose
Loading thread data ...
"Axel Rose" schrieb im Newsbeitrag news:bthgkl$rde$03$ snipped-for-privacy@news.t-online.com...
Hallo Axel, versuch mal den minimum timestep auf 10ms zu setzen falls das bei EWB möglich ist. Bei jedem normalen SPICE geht das. Vielleicht verschätzt sich EWB und deshalb tritt dieser Fehler auf.
Du könntest aber auch ein anderes SPICE-Programm nehmen. Ich empfehle dir das freie LTSPICE. Damit gibt es dieses Problem nicht. Ich habe mich gerade selbst davon überzeugt. Da holt man sich das Programm:
formatting link
Dann File -> Open -> SWCADIII/examples/Educational/astable.asc Die beiden Cs auf 4.7uF ändern und "Run" drücken. Auf der Ausangsspannung sieht man ein paar kleine Artefakte. Die werden beseitigt indem man den Simulatot zwingt spätestens nach 10ms den nächsten Punkt zu berechnen. Dazu Cursor über die Zeile ".tran ..." , dann rechte Maustaste und in der Box im Feld "Max. Timestep" 10m eintragen. Nochmals "Run" und fertig ist die Simulation.
Gruß Helmut
News group:
formatting link

Reply to
Helmut Sennewald
Hi, Ich habe die Erfahrung gemacht, dass man oft die Erdung übersieht. Anfangs rechnet er dann noch ganz gut und nach ein paar ms verschiebts dann alles irgendwo hin. Ausserdem hab ich Probleme 555 Timer zu simulieren. Da gibts ein paar vereinfachte Schaltungen die in der Praxis funktionieren in der Simulation andauernd abstürzen.
Ich denke mal für den wirklich professionellen Einsatz ist es wegen den ungenauen Modellen wahrscheinlich nicht zu empfehlen. Allerdings wenn man genaue Modelle hat, wirds trotzdem gut gehen, weil's ja auch nicht anders rechnet wie Spice (glaub ich mal gelesen zu haben)
Servus Tommi
Reply to
Tommi Reiter
"Tommi Reiter" schrieb im Newsbeitrag news:btk8bt$89u2f$ snipped-for-privacy@ID-28690.news.uni-berlin.de...
Hallo Tommi, welches Programm meinst du jetzt? Ich gehe davon aus, daß du EWB meinst. Das mit dem fehlenden Ground(Erdung) ist wirklich der häufigste Fehler wenn man mit SPICE beginnt.
Bei LTSPICE spielt der 555. Es gibt da in der LTSPICE news group ein weiteres Modell für den 555.
Da muß man sich dann nach guten Modellen umschauen oder selber machen.
Stimmt, EWB basiert auf SPICE, aber die letzte "public"-Version von SPICE hatte Bugs. Nur Firmen die da genug in Bug-Fixes und Verbesserungen investiert haben, haben jetzt ein gutes SPICE.
Gruß Helmut
Reply to
Helmut Sennewald
Hallo Ich habe bei EWB im Menu Analysis Option folgendes umgestellt: Transient Time point iterations von 25 auf 10 und Transiend analysis integration Method von Trapeziodal auf Gear umgestellt. Der Multivibrator kippt regelmäßig hin und her ohne Fehler. Allerdings in dieser Einstellung startet er nicht von allein, wenn er absolut symetrisch aufgebaut wird(was natürlich verständlich ist) Grüße Axel Rose
Reply to
Axel Rose
"Axel Rose" schrieb im Newsbeitrag news:btkia1$upf$00$ snipped-for-privacy@news.t-online.com...
Hallo Axel, der Parameter sagt mir zwar nichts, da ich EWB nicht kenne, aber Hauptsache es hat geholfen. Danke für deine Rückmeldung. Der Nächste mit so einem Problem wird froh sein, wenn er hier die Lösung findet.
Das ist bei LTSPICE auch so. Nur wenn man einen Widerstand z.B. ein Prozent ungleich macht, schwingt der "klassische" astabile Oszillator an.
Gruß Helmut
Reply to
Helmut Sennewald
Ich habe Multisim 7 (das neueste EWB) ausprobiert und es sieht zwar schön aus, aber es liefert falsche Werte. Ich habe auch Kontakt mit der Firma aufgenommen aber ich wurde abgewimmelt, als die merkten, dass sie sich nicht mehr herausreden können. Zu dem ganzen habe ich einen Beitrag in sci.electronics.cad geschrieben:
formatting link
Reply to
Stefan Schmidt
Wenn du noch ne Alternative suchst, ich hab mir mal von der Firma cadence die Lite-Version der Sim.Softw. bestellt. Die haben die CD kostenlos verschickt.Und von den Einschränkungen merkt man nicht wirklich viel, wenn man nicht gerade einen neuen Fernseher entwickelt ;) Kannst ja mal nachschauen.
formatting link

"Axel Rose" schrieb im Newsbeitrag news:bthgkl$rde$03$ snipped-for-privacy@news.t-online.com...
Reply to
Pascal Werner

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.