Combining Custom property fields in BOM

Hi All,
I've got a couple of custom property fields I want to combine into one
in a BOM column.
Say for example I've got a part description (e.g. SIDE PLATE) and I've
got a configuration description (e.g. L/H).
Currently, in my BOM, I've got a column for each. It would be much
tidier if I could combine them into the one column in the BOM so that
it reads "SIDE PLATE L/H".
Is there any way I can do this? The equation feature allows me to
insert one custom property field, but when I append another, it stops
recognising it as a custom property and just prints out the syntax of
what I've entered in the equation editor.
Any help gratefully accepted :)
George.
Reply to
George.Maddever
Loading thread data ...
Dear George,
I had been doing same kind of thing for one of my customer where he wanted me to put part number and description in the same column. For that I created one more custom property and added all the information in that that particular property. And finally you can call that property in your BOM.
Regards
Deepak
Reply to
Engineer
George,
I believe the answer you seek is on a message on this forum. Link here:
formatting link
Matt Lorono
formatting link
of
formatting link
Reply to
fcsuper
Hi Matt,
That helped actually (it was actually my question in the other thread too!). I didn't realise you could call custom properties using the $PRP:"" designation like you can in notes on a drawing sheet. Now I can just make up a statement of $PRP notations and it works!
Problem solved! Thanks!
Reply to
George.Maddever
Reading the combined property (combined in a part config specific Custom Property) in BOM's works well. It doesn't work so well if reporting in drawings of differing Configs it will report the last opened config (found this out at my cost yesterday!!!)
John Layne
formatting link


Reply to
John Layne
Hi John,
Surely the information reported in a BOM will be that of whichever configuration the drawing the BOM is linked to is? I've run some tests and the "combined" column seems to report exactly the same as if I had a separate column for each custom property. What you're reporting sounds more like a bug than an intended shortcoming though.
Under what circumstances does this problem manifest itself?
George.
Reply to
George.Maddever
Yep the BOM thing works fine.
If you try and report a combined config specific custom property, from a part that has multiple configs, in a drawing it will report the combined property from the last opened config not that of the config of the part shown in the drawing. If you open the part hit and CTRL Q it will update to the correct config custom property, BUT if you then open another drawing linked to a different config of the same part that drawings linked properties will show the config properties of the one you just CTRL Q'd.
If I get time over the weekend I'll create a video of the issue and host it. Or if you get the chance pop over I'll make you a coffee and show you the issue. (I had Lindsay confirm the issue, note for everyone else reading George, Lindsay and I work together on occasion)
I thought about reporting this as a bug, but have become disillusioned with the whole bug reporting process. Lack of feedback mainly or SolidWorks Corp state the issue will be fixed in SolidWorks 2008 SP 2
John Layne
formatting link

SolidWorks 2007 SP4.0
Reply to
John Layne

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.