dwg output problems swx2006

I have a customer does plasma cutting and I make dwg files for his nesting
program.
I often use an old dwg to redesign, modify, etc and send him a new dwg.
Sometimes I can just import the dwg directly into a slddrw, converting to
swx entities, do whatever changes and save-as to a dwg again. Hundreds of
times this has worked fine, and the method works great as far as controlling
layers, colors, etc.
Today one of my dwgs has apparently caused a continuity problem on the
nesting program, and sure enough, when I import it into a slddrw, the select
chain fails.
Zooming waaay in, I can find a couple of places where some line entities
have a tiny gap and I can merge these points and select chain does OK.
When I save as dwg and bring it back into slddrw, the problem is back.
Nothing unusual about the file, maybe Solidworks detected that I was getting
something done today, and activated its productivity kill module?
Is there a setting that deals with accuracy of the data points?
Is there any way to do the equivalent of chain-select in DWG editor to
verify if the entities are connected?
bill
Reply to
bill allemann
Loading thread data ...
Not exactly a direct answer, but I have found that saving a SW drawing to ACAD with a view other than 1:1 will produce small gaps that are on the order of the 7th - 8th decimal out. I think what's happening is that SW actually takes the geometry dim and in dividing by the scale factor comes up with a roundoff at that 7-8 decimal place. Since most dims will not be evenly divisible by the scale, that leads to the roundoffs. So then in ACAD, you get the gaps. The best method to eliminate them is to set the SW view to 1:1, then save as ACAD. Then there are no gaps.
WT
Reply to
Wayne Tiffany
I have been working with 1:1 scale all along. The odd thing is I can import this particular dwg into a slddrw (convert to swx entities) and I have gaps. I can immediately import the same dwg and make a sldprt, and the sketch has no gaps. Like I was saying, I've done this procedure on hundreds of files and I don't think this happened more than once or twice before.
I just tried importing the dwg into slddrw again, and I had gaps. This time instead of using trim/extend/merge to fix the gaps, I just dragged the endpoint of one of the entities and let the automatic constraint icon light up in order to mend the gap. It looks like the coincident relation was being lost on a few intersections. When I move the entity around like this, I'm probably getting it out of horizontal, whatever, by the nth decimal, or on the other hand, maybe the error was already there when the intersection disconnected.
I'm kind of thinking about loading up swx2001 again, just to do this customer's stuff.
Bill
Reply to
bill allemann
you know I think I have seen this problem of a spline end not being coincident with a point before but using 2005... not found in printing but in swoopy modelling weird thing was I redid the spline and the coincident relation several times and it was accepted and listed in each attempt but it failed afterward and when you zoomed right in it visibly wasn't coincident don't know if this is related and I cant actually remember what I did as a work around but thought I would mention it I suspect there is a bug there somewhere ;o)
Reply to
neil

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.