ISSUE ON SW2006 S.P.0-Database and Hole wizard error

We tried to install on four PCs (Dell Dimension- XPpro-SP2) SW2006. Everything went smooth during install process. But when we tried to use the hole wizard SW gives an error message like:"unable to open the database.." ,the command stops so that no hole could be introduced in the part. When we exit from command SW works fine and does not crash.. Also if I try to modify an existing part with hole in it, I can edit function, but immediately the error message appears and stops the command (however SW does not crash as well). I've read already some threads about this issue and I tried all the suggested solutions, but none worked. Our reseller suggest to format the PCs, but if possible I wouldn't do it (several other software to install again-lot of waste time). Any suggestion, gentlemen?

Giorgio from Italy

Reply to
Loading thread data ...

I had some problems with 2006 sp0.0 hole wizard. My VAR suggesed the following:

Close SolidWorks then browse to C:\Program Files\\data\ and rename default.mdb to olddefault.mdb.

Then restart SolidWorks.

This fixed my problem, worth trying.


Reply to

This can be an error with file registration. Before you throw in the towel, try registering these files again and restart the computer. Then see if that doesn't fix the problem.

  1. C:\Program Files\Common Files\System\ADO\msado15.DLL
  2. C:\Program Files\Common Files\System\Ole DB\oledb32.DLL
  3. C:\Program Files\Common Files\system\ADO\msadrh15.dll
  4. C:\Program Files\Common Files\System\ADO\msadox.dll
  5. 5. C:\WINDOWS\system32\MSJTES40.dll (use if no database access is possible)

To register a dll:

  1. Close SolidWorks if it is currently running and Open a command line window (DOS window).
  2. Change Directory (cd ...) to the location were the .dll file of interest resides.
  3. At the command prompt, type: regsvr32 "name of .dll file" (without the quotes).
  4. Once you press Enter to run the command you should see a dialogue pop up saying the action was successful.
*to unregister a .dll file just use the command: regsvr32 -u "name of .dll file"(without the quotes).
Reply to

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.