Runtime Error ! R6025

80% of the times when I insert a part in an assembly Solidworks (2007 sp4) locks up and I get a Runtime Error ! pure virtual function call (R6025).

Does any body has any slution or fix for this.



Reply to
Singh S
Loading thread data ...

According to MS, it is a programming error that causes this.

formatting link
I've seen it on a few occasions, but I don't think there is any 'fix' for it. Maybe time for a re-install?


Reply to

Not enough information Singh!

Let tell you for why!

I had that error and the fault turned out to be my network card dying, but not dead. How you may ask! Well my toolbox and templates are on a server, so because I was losing the connection sometimes, I received that error message.

Is your installation using a server? Just SW2007 sp4.0 or office pro version, any add-ins? XP? These things can not be taken for granted.

More Q's Is the part already in the assembly and you are adding another? Is the part full defined and the sketches within fully constrained? Do you get the error when inserting the part or adding a mate to the part? Can you open the part successfully on it's own? Have you tried saving the part to the same folder as the assembly and then inserting? Have you tried suppressing other parts or sub-assemblies in that assembly and then trying to insert the said part? Have you recently defragged your drive with Solidworks on it, if not why not? Have you cleaned up your temp folder?

Just a few things to try!

Reply to

I had this problem on my laptop a while ago, everytime I pressed "copy files" in the pack and go. A repair install of SW fixed that problem.

// Krister

Reply to

Thanks for the reply guys. It is happening on all our machines.

All the files & templets are on Network.

Sw2007 sp4 Premium addins : Space Navigator 3D controls Everything else is turned off

XP pro SP2

Always happens if a new part is inserted. either by dragging or by using insert menu. Once the part is in the assembly I can cntrl+Drag as many with no problem.

Parts are fully defined & contrained

Error only when inserting a part for the firs time.

No problem there.

I will try that.

No. Shouldn't have to do that, but I will try that too.

Every 15 days.

Every Day

I wiped my computer couple of weeks ago and installed everything fresh, XP, SW, Office etc.

I will try different things and see if I can figure something out.

S Singh

Reply to
Singh S

Quote "No. Shouldn't have to do that, but I will try that too."

No you shouldn't have to do this, but, what you are doing is not working and so you will need to try things that are not normal, lol

Does this happen on over assemblies or just this one?

Quote " All the files & templates are on Network".

Quote "Thanks for the reply guys. It is happening on all our machines."

These are massive clues as it then points to a common fault and the only common connection is the network and the server.

Have your IT people, changed access rights, to the folders on the server recently? Very easy to do.

These following ideas will test this theory also-:

1, Dump thought, but the assembly isn't read-only is it, lol, only kidding!

2, Try this, copy all, (every single one), of the files used currently in the assembly, to you local drive. You can use pack and go for the assembly documents, it's the better way of doing it for this exercise. Don't use the flatten folder option, no really, don't!

This will give a folder:- C:\sample C:\sample\copied parts C:\sample\your toolbox items

Then copy the parts, that are causing the error message, to the same root folder of the assembly.

In this example C:\sample

use the Copy Setting Wizard and store this file on your local PC, to use later, (must do action!!) Shut down the PC Disconnect the network cable. Restart your PC, restart Solidworks, (it will complain about not finding things for sure, but ignore for now), and then try to open the assembly and insert the part.

Still doesn't work?

3, Close all open programs.

If you are ok, with editing the registry, the next step to set Solidworks to default settings. Run Regedit Scroll to- HKEY_CURRENT _USER/Software

Find the Solidworks entry and rename it to Solidworksold. Close Regedit

Start Solidworks and all of the installation defaults will load.

Restart Solidworks, and then try to open the assembly and insert the part.

If these actions fail, close all open programs Run Regedit Scroll to- HKEY_CURRENT _USER/Software

Find the Solidworks entry and Delete it. Rename Solidworksold to Solidworks. Close Regedit

This will restore the previous solidworks settings.

Then shut down the PC, reconnect the network cable and restart the PC.

After re-connecting to the network, run the Copy Setting Wizard again to restore your previous settings.

Let me know the results.


Reply to

PolyTech Forum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.